Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Plugins & Atahualpa (http://forum.bytesforall.com/forumdisplay.php?f=16)
-   -   [SOLVED] Atahualpa 3.7.3 and Sociable 3.5.2 (http://forum.bytesforall.com/showthread.php?t=16381)

Zenman Jan 1, 2012 03:29 PM

[SOLVED] Atahualpa 3.7.3 and Sociable 3.5.2
1 Attachment(s)
I'm preparing a full upgrade of my site. Of course I'm testing all of this on my local harddrive with Xampp.

The upgrade to WP3.3 went OK, my update from Atahualpa 3.6.4 to 3.7.3 went pretty well except for one thing.

My Sociable-icons on pages show up nicely, but the sociable-icons in the post-footer is replaced by this error-message:
Fatal error: Call to undefined function do_sociable() in C:\xampp\htdocs\wordpress\wp-content\themes\atahualpa\functions\bfa_postinfo.ph p on line 465

The right sidebar also has a problem when browsing through posts, it does not show up at all. Browsing through pages brings back the sidebar...

So I tried a suggestion I read on this forum. Modifying bfa_postinfo.php however did nothing.

An update of the Sociable-plugin does not work for me as it does not offer the icons I need. What else can I try?

juggledad Jan 1, 2012 03:40 PM

did you try upgrading the sociable plugin?

Zenman Jan 1, 2012 04:02 PM

Yes, I did. The plugin is a bit different and does not provide all the icons I need. Also it does not work within the footer of posts. The error is gone, but the selected icons do not show up. It shows five squares and when I hover over them, the tiptool shows the titles of my old five icons (including Hyves and Print which are gone in the new version of Sociable). The hyperlinks added to the squares are incorrect too.


juggledad Jan 2, 2012 08:59 AM

1 Attachment(s)
Here try this - it is untested but is intended to work with either version of the sociable plugin

Attachment 1707

Zenman Jan 2, 2012 09:22 AM

Thanks! This one works great with my older version of Sociable (3.5.2).

When updating to Sociable version 4.x I still can't get the icons to show up in the footer of my posts. The icons do show up on pages.

For now, I'm happy.

Zenman Jan 4, 2012 05:19 AM

Whoops! Went live today (WP 3.3.1) and my last action was updating to Atahualpa 373.

After the update I got the (known) error-message in the postfooter, so I placed the bfa_postinfo.php you provided me with.

Something is very wrong now. My site totally went down because of an error in bfa_postinfo.php on line 475.

I think there are two "(" signs that are not closed by a ")".

As a quick solution I uploaded the 364 version of bfa_postinfo.php. My site went up again with a proper post-footer, but now my breadcrumsNavXT (v4.01) doesn't show up anymore...

Line 475 is the second if-statement in the code below. It starts with two "("-signs. The elseif-statement a few lines further also starts with two "("-signs...
Another thing that might be incorrect is the ":"-sign after "do_sociable()". Should this not be an ";"-sign?

Wrong? code:
PHP Code:

    // For the "Sociable" plugin
if ( strpos($postinfo_string,'%sociable%') !== FALSE ) {
            if ( (
function_exists('sociable_html2') AND function_existsdo_sociable() ) ) {
$sociable ob_get_contents();
            } elseif ( (
function_exists('sociable_html2') AND function_exists('sociable_html') ) {
$sociable sociable_html2();
            } else {
$sociable "";
$postinfo str_replace("%sociable%"$sociable$postinfo);

juggledad Jan 4, 2012 06:29 AM

let me take a look

Zenman Jan 4, 2012 06:37 AM

Figured out the breadcrumb-thing. Had to edit index.php. I placed this:

HTML Code:

        <div class="breadcrumbs">
                <?php if(function_exists('bcn_display'))


In between these two lines:

PHP Code:

    <?php bfa_next_previous_page_links('Top'); // For MULTI post pages if activated at ATO -> Next/Previous Navigation:  ?>

    <?php while (have_posts()) : the_post(); $bfa_ata['postcount']++; ?>

I hope you can solve my footer-problem...

juggledad Jan 4, 2012 06:43 AM

1 Attachment(s)
this version will work with both versions of sociable
Attachment 1710

Zenman Jan 4, 2012 07:09 AM

Yeah! Now it works!

Thanks again.


All times are GMT -6. The time now is 07:31 PM.

Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.