Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Sidebars & Widgets (http://forum.bytesforall.com/forumdisplay.php?f=14)
-   -   Side bars will not go away for pages as I expected them to do. (http://forum.bytesforall.com/showthread.php?t=17245)

bsprowl Apr 8, 2012 05:36 PM

Side bars will not go away for pages as I expected them to do.
 
I'm using the WP 3.3.1 and Atahualpa 3.7.3 with WP Forum Server 1.7.3.

I went to the Sidebar options and listed the pages where I wanted the left Sidebar to be suppressed.

Nothing happened. The Sidebar is still there. Checked my page IDs and even put the exception list in every left SIdebar type. Still there.

Site is FE-muscle/wordpress/forumpress.com. The exception is supposed to be all (any) Forum pages.

Thanks,

Bob

juggledad Apr 8, 2012 07:18 PM

If you want all the blog pages to not have a sidebar AND the blog page is not the lront page, unchecking the box for 'Homepage' in the 'xxxxxx sidebar: Display on:' option

bsprowl Apr 8, 2012 08:56 PM

I want the forum's pages (categories) to not have the left sidebar. (Access to the site will be through Menu One at the top of the page or Menu 2 just above the Forum.)

The rest of the site should have the Sidebar.

I just tested by unchecking all of the "Left Sidebar: Display On" options then adding them one at a time and found that with none checked I of course did not get a left Sidebar ever - even on the category pages not listed, with Homepage and/or Front Page checked I again don't a left Sidebar anywhere, but when I check "Page" pages [what the Quotes mean is unknown to me] I get the left Sidebar always. Checking the "Pages" page check box alone seems to work the same way - left Sidebar everywhere.

Checking the Categories box alone or with Homepage and/or Front Page checked I again don't a left Sidebar anywhere.

I don't know how to control the Sidebar. The instructions frankly don't work although your suggestion at least let me turn the Sidebar off but not the way I expected it to work.

Thanks,

Bob

juggledad Apr 9, 2012 06:05 AM

You ned to understand the terminology that WordPress uses (this is NOT theme related, it applies to every theme) and it can get a little confusing.

In the backend, WordPress has posts and pages. A page is actually a special type of post.
A post is an entry that makes up your blog, post tend to happen frequently.
A page is comprised of static data.

In the front end, what you see on the screen is considered a page. Your blog page generally is composed of many posts. This is referred to as a 'multi-post' page. When you look at a single post, this is referred to as a 'single post' page. When you look at a actual page this is referred to as a 'page' page.

WordPress also uses the terminology homepage and front page. The home page references your blog page (why they didn't call it the 'blog' page I have no idea). The front page is the page the user will see when they type in your URL. The page that shows when you first enter your URL is defined in the reading settings .front page displays.

If you have set 'front page displays' to 'your latest posts' - then the page you see when you type in your URL is called both the 'front page' and the 'home page'.

If you have set 'front page displays' a static page, then the front page would select will be your 'front page' and the 'post page' will be called the 'home page'.

(are you confused yet? It took me a while to get this straight in my own mind.)

A category page is a list of posts from a particular category.

So now to your problem. If you do not want the left sidebar to show on all category pages, simply go to the 'style and configure sidebars 'section and in the 'left sidebar: display on:' uncheck the 'category pages' option.

that should be all you need to do.

SharonJ Sep 26, 2014 01:34 PM

thank you. This thread helped me realize why sidebars were not appearing on my Blog page. I did not want widgets to show on my home page so had unclicked Home and Front pages for sidebars and used inner sidebars for the main page only.

the main page had no widgets, all other pages EXCEPT the blog page showed right and left sidebars with widgets.

Once I ticked Home on both sidebars, they appeared on the blog page immediately. Front remained unchecked and all is well.


All times are GMT -6. The time now is 05:12 AM.

Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.