Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   New Versions, & Updating (http://forum.bytesforall.com/forumdisplay.php?f=12)
-   -   [SOLVED] Redirection to web page outside blog when click on 'Posts', 'Comments' or ' (http://forum.bytesforall.com/showthread.php?t=12206)

brianwilson71 Jan 13, 2011 04:51 AM

[SOLVED] Redirection to web page outside blog when click on 'Posts', 'Comments' or '
 
Hi, I am brand new to Atahualpa and have just installed version 3.6.1.

I have installed wordpress to www.abipo.com/blog/

Heres the problem:

When I click on 'Posts' or 'Comments' at the top of the blog, I get redirected to www.abipo.com/index.html (i.e. a webpage that is OUTSIDE the blog).

Also, for certain widgets I install, for example the 'Search' widget, I get get reredirected to www.abipo.com/index.html when I click on 'Search'.

Any ideas whats going on?

Thanks,

/Brian

juggledad Jan 13, 2011 05:45 AM

have you tried disabling all our plugins to see if there is a conflict?

brianwilson71 Jan 13, 2011 06:39 AM

Hi juggledad,

I don't have so many plugins (just akismet and google analytics) as I have only installed yesterday but good suggestion. I have disabled and it doesn't make any difference.

You can see the problem if you go here and click on 'Posts' in the top right:

www.abipo.com/blog/

Any other ideas?

Thanks for your help

juggledad Jan 13, 2011 07:10 AM

this looks like is is installed where another site is installed - in a sub folder. You should check the htaccess file of the root folder and see what it is doing, if may be doing the redirect.

If you don't know what an htaccess file is, I suggest doing (a lot of) research on the web or contacting someone in your organization or at your host who might help you.

brianwilson71 Jan 13, 2011 07:36 AM

Note: I am running on a windows server but this is all that is in the .htaccess file:


AddType application/x-httpd-parse .htm
AuthUserFile [path]/abipo.com/.htpasswd
AuthGroupFile [path]/abipo.com/.htgroup
AuthName "Site Studio"
AuthType Basic
deny from all


Should I need to be dipping into this file from a standard install of the theme?

brianwilson71 Jan 13, 2011 07:37 AM

... and yes, it is installed in a '/blog/' subfolder from the root as I want to keep the website and the blog separate... but I thought that would have been pretty standard stuff?

brianwilson71 Jan 13, 2011 07:39 AM

Just reverted to twenty ten theme and have the same problem with the 'search' functionality... looks like its some sort of problem with the wordpress install and not the theme...

juggledad Jan 13, 2011 07:39 AM

what are your permalinsk set to? (dashboard->settings->permalinks)

brianwilson71 Jan 13, 2011 07:55 AM

Set to default. I did modify them but set them back to default before posting the problem here. You got me thinking. I think its something to do with Wordpress not redirecting to the /blog/ folder. Still stuck tho

brianwilson71 Jan 13, 2011 08:07 AM

Got it!

In General Settings I had set:

WordPress Address (URL) to www.abipo.com/blog

and

Site Address (URL) to www.abipo.com


Seemed logical to me. For some reason they both should be set to www.abipo.com/blog and then it works!!

Man!


All times are GMT -6. The time now is 02:22 AM.

Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.