Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Comments, trackbacks & pings (http://forum.bytesforall.com/forumdisplay.php?f=19)
-   -   How not to append the profile URL to the username in comments (http://forum.bytesforall.com/showthread.php?t=21516)

flyboy Feb 16, 2014 12:07 PM

How not to append the profile URL to the username in comments
 
I have a bit of a conundrum. In my profile I have added my Google authorship URL so I can set the Atahualpa to automatically add authorship to every piece of content I create.

But that started adding it to my comments as well.

I had a temporary fix for a while (essentially placing my authorship in the Atahualpa settings), but I am now looking to have guest authors on my site and would like to give them the capability to have their authorship featured as well.

Which means that I need to source the URL from their profile, but i need to do it without it showing up in the comments. As it is right now, no matter who posts, my name and my authorship shows up (since I had to hard-code it in the byline window)

How can I prevent all user's names from becoming a link in the comments area only, without rendering Atahualpa un-updateable (I don't want to start messing with the php)

lmilesw Feb 16, 2014 01:14 PM

I'm not 100% sure of what you want to do but how about using CSS to hide what you don't want to show?

flyboy Feb 18, 2014 01:49 PM

I am trying to prevent having a profile URL from being used as a link in comments, but inserted in a byline instead.

That would allow me to add Google authorship for all contributors of the blog without having the said authorship appear in the comments.

Comments have a rel nofollow attribute automatically added to them, while authorship has rel author. Having two rel attributes in a link is bad on many levels, but as of recently even worse due to attempts of authorship jacking through comment posts, which Google may be penalizing soon (they certainly no longer honor it as it's quite a blackhat technique).

The simplest solution would be to disable placing the profile URL in the comment, but I can't figure out how to pull it off without changing the code to Atahualpa (which would make it hard to update it)

lmilesw Feb 18, 2014 02:15 PM

Can you send a link to an example?

juggledad Feb 18, 2014 02:32 PM

beside the linků
Quote:

In my profile I have added my Google authorship URL so I can set the Atahualpa to automatically add authorship to every piece of content I create.
so you edited your user profile..where did you add the url?

flyboy Feb 20, 2014 01:30 AM

I placed it in the "website" field.

Also, @lmilesw, i'd love to give you an example, but I just finished manually removing all instances of URLs in my comment name just few days ago. So I have no example to give you. But it's pretty much the usual stuff you get when your profile contains a URL

juggledad Feb 20, 2014 01:57 AM

It's my understanding, when you make a comment, if you are logged in, the website info from your user ID is added to the comment row in the database by WordPress. To change this you would have to have edit the wp core or possibly find a plugin if one exists.

In addition, if you have the website set to URL A and make some comments, then change it to URL B, the old comments will still show URL A.

flyboy Feb 23, 2014 04:49 PM

Thank you JD, I'll look up the plugin


All times are GMT -6. The time now is 02:51 AM.

Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.