Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Atahualpa 3 Wordpress theme (http://forum.bytesforall.com/forumdisplay.php?f=2)
-   -   [SOLVED] Database Restore - Atahualpa Settings gone (total panic...) (http://forum.bytesforall.com/showthread.php?t=18804)

Fux Oct 31, 2012 04:24 AM

[SOLVED] Database Restore - Atahualpa Settings gone (total panic...)
 
Hi,
I've had to move to a new database. So what I did was
1. put WP in maintenance
2. export database via PHPMySQL
3. Import into new Database via PHPMySQL
4. reconfigure wp-config.
5. exit maintenance mode

The result: The design has changed a lot. After a first panic attack I realized that Atahualpa (I am using 3.7.7) has gone back to a very old revision of my design that is at least 6 months old.

What could have happened? Does Ata still store all the variables in the DB (I remember there has been a change in the way it handles its design settings a while ago)? Or have they moved to a separate text file? I am at a total loss and have no idea how to fix this. Unfortunately, the old database seems to be broken now as well. It is possible, though, that while importing to the new databse (had to do it in small packages) I switched to the old database (in a separate window) to check something and the import to the new DB actually went to the old one (some strange PHPMySQL-behaviour - never open it in separate windows...).
So, of course I got backups, but obviously they don't work. Could there be anything wrong with the character set?

Or what? Please help me. Thank you.

juggledad Oct 31, 2012 04:32 AM

First - check to see if Atahualpa is the selected theme.

Fux Oct 31, 2012 04:47 AM

Thank you. It is the selected theme.

As far as I can see the settings (in the wp_options table) really are very old. That makes no sense, I make daily backups. Could that be legacy data? Where does Atahualpa store the style data?

Update: Yes, just checked it. The current Atahualpa version is the latest I used (3.7.7), but the custom data (e.g. CSS inserts) is a YEARS old set. I checked in the the SQL file and it seems to match. How can this happen?

juggledad Oct 31, 2012 04:49 AM

Atahualpa stores it's options in the database in a single row of the wp-options table.
Do you have a complete database backup - ie all in one file?
where are you located and do you skype?

Fux Oct 31, 2012 04:58 AM

I sent you a PM.

Update: Oh and yes: All in one file. Sorry for the panic but this is really important for me.

juggledad Oct 31, 2012 05:11 AM

did not get the PM

Fux Oct 31, 2012 05:15 AM

OK: Located in Germany, Skype name "felixkitchen", but headset broken.

juggledad Oct 31, 2012 05:27 AM

Are all your posts there? and pages?
is the only thing missing the theme design?

Fux Oct 31, 2012 05:28 AM

As far as I can see, yes. Everything is there. posts, comments, widgets. A perfectly usable site - but ugly because the design does not work anymore (it is old, many images I used back then are not there anymore etc).

Fux Oct 31, 2012 05:38 AM

I have found the line: 'bfa_ata4' - its content looks as though it were what I need. I am pretty sure. The question is: Why does Atahualpa not choose to use it and instead revert to the old setting? ('bfa_...')?

What could have happened?
- It is totally possible that I messed up and imported data into the old (original) database and it is very possible that happened with the options set.
- The backup I made (with the phpMySQL standard settings) might be in the wrong character set (I don't know anything about that stuff)
- Re-importing the wp_options section into the original database might not work entirely because there is "something" wrong with the char set.
- Of course there are many other possibilities, but these are only ones I can think of. It sounds like it should be easy to fix for someone who knows what he is doing...

juggledad Oct 31, 2012 05:47 AM

go read your PM's (upper right hand corner of the screen)

juggledad Oct 31, 2012 06:54 AM

1 Attachment(s)
Try using this and importing it into the Atahualpa options (ata->export/import settings)

Fux Oct 31, 2012 07:58 AM

That worked. Thanks a lot. In the meantime I had started to fiddle that line together, replacing all those ';' and ':' by hand. I did not know anything else I could do. I was just done...

Now, how did this happen and how can I prevent it from happening again when I try to move to the newe DB next time?

juggledad Oct 31, 2012 10:25 AM

How did it happen, beats me, you messed something up along the way.
what would I do the next time: Me I use the plugin BackupBuddy (a paid plugin) to move and backup sites.

Fux Nov 2, 2012 08:55 AM

Ok, thanks again. Just in case this might be interesting: Using phpMySQL to export/import the database content always results in the new database showing "?" instead of "", ""... in the wordpress posts. Might be related to this: http://stackoverflow.com/questions/5...ssue-revisited

When using the WP-DBManager Plugin everything works smoothly (I just forgot about its Restore-capabilities.

I am writing this because I imagine (in my non-MySQL-understanding brain) that there could be some trouble with the way (i.e. the Char Set) Atahualpa stores its data in the Database. Maybe this might help anyone, maybe not.

juggledad Nov 2, 2012 09:28 AM

if it is showing wth the Atahualpa settings it could be because I imported your DB and didn't pay attention to the character set :o


All times are GMT -6. The time now is 04:58 AM.

Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.