Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Header configuration & styling (http://forum.bytesforall.com/forumdisplay.php?f=15)
-   -   [SOLVED] 2 little issues I'm having (no header image in firefox & problem with page m (http://forum.bytesforall.com/showthread.php?t=1141)

andytaylor Apr 7, 2009 06:01 AM

[SOLVED] 2 little issues I'm having (no header image in firefox & problem with page m
 
Thanks for all the help I received the other day about getting the background colour changed, but now I'm back again! (I have donated by the way). Absolutely love this theme by the way.


So, firstly, I've been editing the theme in Google Chrome, and checking how it's looking in internet explorer. All's fine there, but when I looked at in in Firefox, there's no header image! Here is my website address:

www.charnwoodchillis.co.uk

At first I thought it was because I was using a .png file for the header, but then I changed it for a jpeg and it still doesn't seem to work.


Then, secondly, I think this might be just a quirk of the theme, but I've got a page menu bar (which works great. Thanks!) but I want a static page to appear when people type in the website adress and I want the actual blog to be under the "News" section.

So I did a quick bit of research and found out how to do that. I just went to "settings"-> "Reading" and changed the "Frontpage" to a static page called "Homepage". But now I've done that the menu bar doesn't work (it looks like it now thinks that all of wordpress is under the directory /?page_id=29 so obviously it doesn't work when it tries to find /?page_id=29/?page_id=27 or whatever).

All I'm after is a static page to come up as the home page, so if there's any other way of doing that, that'd be a real help.

Any help with either of these two things would be great. Thanks.

andytaylor Apr 7, 2009 05:02 PM

Well, just in case anybody else is reading this with the same problem, I found the answer to one of my problems.

The reason that the header wasn't showing in firefox was because the image name had a space in its file name. I took that out and all was fine again.

Still having trouble with the menu bar though. I just de-selected the Settings->Reading Front page setting and it's still playing up. Clicking on any of the links always takes me to the same page! Any thoughts?

If you click the link in my previous post, you'll see the problem in the menu bar across the top.

Thanks.

Flynn Apr 8, 2009 10:06 AM

Your site isn't loading for me, 500 server error.

Settings -> Reading -> Frontpage display as:

is right

This is what you should have done:

1. Create a static page titled "Homepage"
2. Create a static page titled "News"
3. At Settings -> Reading -> Frontpage display as , choose:
"A static page (select below)"
Frontpage: Homepage
Posts Page: News

At Settings -> General you should have:

WordPress address (URL): http://www.charnwoodchillis.co.uk
Blog address (URL): http://www.charnwoodchillis.co.uk

At Settings -> Permalinks you should have:
Common Settings: Default
(as you don't seem to use Permalinks)

Try saving the Permalinks settings again by clicking "Save changes".

If you have all this and it still doesn't work please post in this thread again once your site is up so I can see the thread

andytaylor Jun 8, 2009 04:14 AM

Hi, I was just generally searching through the web and came across this again. To be honest I'd forgotten that I'd posted here.

Thanks very much for the reply, I got it figured out, the website looks great and has been working perfectly for the last couple of months.

Sorry it's taken several months to say thank you!

Andy Taylor.


All times are GMT -6. The time now is 01:12 PM.

Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.