Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Plugins & Atahualpa (http://forum.bytesforall.com/forumdisplay.php?f=16)
-   -   Cannot Edit or Delete WPFORO posts (http://forum.bytesforall.com/showthread.php?t=23965)

jjacoberger May 8, 2017 10:46 AM

Cannot Edit or Delete WPFORO posts
 
All of a sudden, for the past few days, I have been unable to edit or delete posts in my WPFORO forums, which had been working previously.

I turned on Wordpress debugging and get these errors in debug.log when I try to edit or delete:

[08-May-2017 16:42:29 UTC] PHP Notice: Undefined index: animate_cat_menu_bar in /home3/doylest3/public_html/wp-content/themes/atahualpa/js.php on line 79
[08-May-2017 16:42:36 UTC] PHP Notice: Undefined index: animate_cat_menu_bar in /home3/doylest3/public_html/wp-content/themes/atahualpa/js.php on line 79

I have tried deactivating other plugins but that does not correct the issue.

juggledad May 8, 2017 01:48 PM

What versions are you using?
what happens if you switch to the twenty seventeen theme?

jjacoberger May 8, 2017 02:30 PM

I'm running:
Wordpress 4.7.4
PHP 5.6
Atahualpa 3.7.23

I will try switching to twenty seventeen and see what happens when I get a chance this evening.

fyi: the url to the site is: www.doylestownphotoclub.org

Update: I tried both the twenty seventeen and twenty sixteen themes and everything worked

juggledad May 8, 2017 03:08 PM

Please go to ATO->Export/Import Settings export your settings and attach them to a reply (paper clip icon)

jjacoberger May 8, 2017 03:57 PM

1 Attachment(s)
Export attached.

Something Interesting:

I downloaded atahualpa 3.7.2.4 and put it in a new theme directory. From my live site, if I do a preview and go to the forums, the edit and delete work fine. If I make that copy of the theme active, then they no longer work. Conversely, if I do a live preview of my original theme, the functions work there.

This has me stumped.

juggledad May 8, 2017 06:18 PM

did you disable ALL your plugins at the same time to see if you could then edit a post?

juggledad May 8, 2017 06:51 PM

I just installed the WPFORO plugin and I have no issues and this is using your Atahualpa theme options.

But lets first resolve the missing index issue. First off backup your site.

Now that you have a backup, go to ATO->MENU 2 (Category Menu). You should see that the first selection is blank - it should be YES or NO. Why this is blank. I don't know but if you go to the bottom of the page and press the RED 'Reset Settings" button, that should fix the missing index message you were seeing.

Now you can test your editing again and see if it works.

If it doesn't then you need to go into more detail about this. You must understand, before you opened this issue, I'd never heard of this plugin.

What changed in the few days since it worked?
where you are doing the edit? front end/backend?
what are ALL the settings you have for the plugin?
do you let anyone create a user on your site?

jjacoberger May 9, 2017 07:19 AM

Yes, I disabled every plugin except wpforo and edit and delete still didn't work.

No changes were made to the site except for some text changes to existing pages.

I noticed Edit and Delete were not working Saturday afternoon. About 11:00pm on Saturday they did work for about an hour then stopped again. This is all from the front end.

Users cannot register for the site, they are all added manually by an admin.

I have re-installed wordpress and atahualpa. Today I will do a complete fresh install of wpforo including re-building the databases to see if that makes any difference.

I do think it's curious that it all works fine in a live preview of the theme but then stops when I make the theme active.

I will post another update after the forums have been re-built.

juggledad May 9, 2017 07:54 AM

You might want to ask your host if they did anything (server maintenance) about that time.

jjacoberger May 10, 2017 01:38 PM

Well, I do appreciate your help.

After the clean install, it worked, until I logged out of the site and logged back in again later.

There were no hosting changes. Gvectors, the WPFORO developers see nothing wrong now that those js errors were cleared up when I reset defaults on MENU2.

The only atahualpa related error that occasionally shows up in debug.log now is:
[10-May-2017 17:58:08 UTC] PHP Notice: Undefined index: HTTP_USER_AGENT in /home3/doylest3/public_html/wp-content/themes/atahualpa/functions.php on line 870

I don't know what if anything that would affect, or if there is anything I can do to resolve that.

I think it may just be time to switch to another forum and move on.

thank you very much

juggledad May 10, 2017 01:57 PM

Interesting, line 870 of function.php icontains a single '}'

The only place HTTP_USER_AGENT is used is on line 846 which leads me to think there are an extra 24 lines in your function.php.....

If you haven't added any code to function.php....

could you give me access to teh site so I can take a look? If so, send me a PM with an admin ID/PW

juggledad May 10, 2017 04:02 PM

Ok I checked your version of function.php and it is exactly the same as mine, they both have the same number of lines so I don't know why it would be reporting the error line as 870.

Another interesting thing I saw is that when you go to a forum and look, you will see a reply area at teh bottom of teh page. When you press teh 'edit' link, reply gets changed to EDIT but the text from the post does not show up and if you enter something, it just becomes a reply.

I'm going to do some testing here and I'll get back to you.

juggledad May 10, 2017 05:18 PM

Sorry, but I can not recreate your issue. Atahualpa and WPFORO work fine in my install.


All times are GMT -6. The time now is 11:48 PM.

Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.