Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Forum How-To (http://forum.bytesforall.com/forumdisplay.php?f=9)
-   -   Text and Images will not line up in posts/pages, all over the place. (http://forum.bytesforall.com/showthread.php?t=3145)

ngb222 Aug 25, 2009 11:37 PM

Merged: Image floating issue in posts
 
My question is , all my clients are having the exact same problem when I use this theme.
When we add images and text wrap, the images get on top of each other or lay out in a decending pattern.
It is a mess. I am really getting worn out trying to figure this out for people.
I have resorted to inserting lines and coloring them white to make the sections stay apart.
I have about 8 Wordpress themes I use, (studio press) and this theme is the only one I have this issue with,
I love this theme but this is a deal breaker lately for me with clients.
It is very time consuming and I don't even know why it keeps happening. A reason and solution would be wonderful.

Thanks

Please look at this, I need help, images stacking in posts and pages

http://askmepc-webdesign.com/wpimageproblem.png

I have this with all the Atahualpa themes I use.
I need to understand why this happening so I can fix it.

Thank you.
Also I did not know what thread is correct for this.
I did not see a general questions thread.

juggledad Aug 26, 2009 08:06 PM

What version ao Atahualpa, WP and PHP
What is the URL - point to an example.

Flynn Aug 27, 2009 10:20 PM

Add

clear:left

to the paragraphs or the images, or both, hard to tell from just the image.

Example CSS Insert:

div.post-bodycopy p {
clear:left;
}

ngb222 Aug 28, 2009 11:18 AM

the url is judithmarshall.net/writing-tips/
I added that in the insert css section and it still is whack.

Please view the url so I can figure this out. It happens to me all the time with this theme.

This is vs 3.3 I was using your more recent version 3.4 and I had to go back, since I was running into lots of small issues causing me trouble and when you were on vacation, I was advised to go back to the older version. I am gun shy now, since I don't have time and people obviously don't want to pay me more to redo these sites after I set them up.
I use your theme frequently.

juggledad Aug 28, 2009 11:58 AM

When you create your posts, are you copying from Word and pasting into the posts? The reason I ask is that I'm seeing
HTML Code:

<p class="MsoNormal" style="margin: 11.25pt 52.5pt 11.25pt 0in;">
in the source and that is typically what you get doing a copy and paste from Word and that can cause all kinds of 'issues'

ngb222 Aug 28, 2009 07:08 PM

I created a page using straight text from notepad, and I even tested this by just typing in text and adding the images, it still does this. As soon as you add white space and a third image it starts to go all over the page and there is no way to make it behave, we tried working in the html vs. visual and
we stripped out any coding that may interfer and it still does it.
I can not be the only person having this problem. I am so baffled. I had another guy who is really good at wordpress work on it with me, and he tried to add page breaks and we worked on it and it still did the same thing.
Anyone else have this problem and finding a solution?

Flynn Aug 28, 2009 08:53 PM

MSO means Microsoft Office and indicates that content was pasted directly from Word or similar software, which should be avoided.

The CSS Insert I suggested doesn't work because the div.post-bodycopy was removed on your site, which would have had a class "clearfix" to avoid the issues you have

Use this instead then

div.post p {
clear:left
}

or add the class "clearfix" to the div.post, or do both

There are also some unnecessary SPAN tags etc., it would be better to clear these posts and build them up again from scratch to get rid of all these MSO and whatever tags

juggledad Aug 29, 2009 08:30 AM

You can create the post as a table and get it to work, try this
HTML Code:

<table>
<tr>Writing Tips – The Heart and Craft of Writing Fiction
</tr>
<tr><td>
<img class="alignleft size-full wp-image-236" title="tip1" src="http://judithmarshall.net/wp-content/uploads/2009/08/tip13.png" alt="tip1" width="124" height="121" />
</td>
<td>
Where to start? Some people prefer to begin by sketching out a plot line, perhaps using something like, “The Writer’s Journey,” by Christopher Vogler, or “Blockbuster Plots: Pure and Simple,” by Martha Alderson, as a guide. Others, like myself, prefer to start with an idea and then sit down at the computer and let it rip! I enjoy seeing where the characters will take me, rather than trying to steer them in a certain direction. Sometimes they surprise me with the actions they take, the language they use or even the bizarre thoughts they have. That, for me, is the joy of writing; the mystery of what the characters will do next. It’s all up to them.
</td>
</tr>
<tr>
<td>
<img class="alignleft size-full wp-image-241" title="tip2" src="http://judithmarshall.net/wp-content/uploads/2009/08/tip25.png" alt="tip2" width="122" height="121" />
</td>
<td>
When to revise? There’s no right or wrong answer to this question. Some writers prefer to look at what they’ve written the previous day before stating anything new; others revise as they go. I’d never finish if I used that process. My advice is to plow through to the end before you start of revise. I know it’s difficult, but the best way to get a novel written is to write. I’m a proponent of Anne Lamott’s advice, “Write lots of shitty first drafts.” Believe me, you’ll have plenty of time to revise later.
</td>
</tr>
<tr>
<td>
<img class="alignleft size-full wp-image-242" title="tip3" src="http://judithmarshall.net/wp-content/uploads/2009/08/tip31.png" alt="tip3" width="126" height="126" />
</td>
<td>
What to do with the good parts you cut out?

When you do begin to review the first draft, there will undoubtedly be lovely description words, phrases, or paragraphs that you want to save to maybe use elsewhere. This is where “cut and paste,” comes in. Start a new word document (I affectionately call mine, “leftovers”), and then paste anything you want to save there I can’t tell you how many times I’ve found exactly what I needed on my “leftovers” document.
</td>
</tr>
</table>


ngb222 Aug 29, 2009 11:38 AM

How did I do this? I did not remove anything on purpose. How do I get it back so I can use this "clearfix"

"The CSS Insert I suggested doesn't work because the div.post-bodycopy was removed on your site, which would have had a class "clearfix" to avoid the issues you have"

I removed it from my site?

I will clear the MSO stuff, but we did try this from straight notepad text and it does the same thing.
I even did a version from scatch, typing the text straight into the post and it still did this.
That is why I came in here, I am baffled.

Flynn Aug 29, 2009 12:27 PM

There was one Atahualpa version where the div.post-bodycopy was missing. You must be using that older version then. I suggest that you use a current version of Atahualpa

ngb222 Aug 29, 2009 02:48 PM

I installed the latest theme, and now nothing will text wrap.
Now the home page is really messed up. ( the aboutme page)
Now what to do?
Look at my test page. A mess. This was created from notepad, not word.
http://judithmarshall.net/?page_id=309

juggledad Aug 29, 2009 07:21 PM

the test page gives a 'Not Found'

ngb222 Aug 30, 2009 10:51 AM

I just clicked it and went straight there.

http://judithmarshall.net/?page_id=309

This layout is what happens as soon as you add more then two images.
It is like Wordpress will not allow any white space between images with the text aligned and the next set.
I installed raw html and tried disabling WP formatting but it still does it.

I still need help. Thanks

juggledad Sep 8, 2009 05:18 AM

when I click on the link, I still get
HTML Code:

NOT FOUND
Sorry, but you are looking for something that isn't here.


edanto Dec 30, 2009 05:11 PM

Hi ngb222,

I'm having a similar problem to you - but this is the first theme I've really used and I'm a bit out of my depth. I would also like to know how to easily put multiple images into a page.

Looking at your problem page - http://judithmarshall.net/writing-tips/ - I see that it's not fixed yet.

Have you gotten it to work with any other website? thanks

paulae Dec 30, 2009 05:30 PM

First of all, the Judith Marshall page has the dreaded Word code in it. She probably pasted directly from a Word document. Don't do that in Wordpress! It makes it hard to get the text the way you want it. If I ever do have to paste some Word text, I first remove all the Word formatting by running it through the Tiny MCE Advanced plugin's Word-ugliness remover.

I'm not sure what else might be going wrong, but I don't have this problem with the theme. Might be time to move up to 3.4.4 anyway, though..

lmilesw Dec 30, 2009 07:22 PM

I just tried something that seems to work for the "stacking images" issue. I put a div around each image/text section with a style of clear:both. An easier way to do this in the html editor is to use the Koumpounophobia plugin. I tested on both FF and IE and it worked fine.

ngb222 May 27, 2010 10:31 AM

Back again with same issue! larry can you tell me where and what exactly to insert.
I added the code to align left but now all my text wrapping was knocked out.
http://greatdeals-bargains.com/links/

I created this page in an html doc and dropped it in.
I need the exact code to add please.
My clients want their images to align left and be able to text wrap.
Thank you!!

ngb222 May 27, 2010 10:43 AM

Quote:

Originally Posted by Flynn (Post 13680)
There was one Atahualpa version where the div.post-bodycopy was missing. You must be using that older version then. I suggest that you use a current version of Atahualpa


BTW what version was missing that what is the fix?
I am using 3.4

I do not want to update for many reasons this site has been a nightmare already.

lmilesw May 27, 2010 11:04 AM

The URL take you to a "Coming Soon" page.

ngb222 May 27, 2010 11:08 AM

Quote:

Originally Posted by lmilesw (Post 32919)
The URL take you to a "Coming Soon" page.


Sorry about that, take a look now, thanks! (btw, I know there is some mso left in there.)
I train my clients how to run their own blogs and they end up with some formatting still but it is not a problem with my other themes.
http://greatdeals-bargains.com/links/

lmilesw May 27, 2010 11:48 AM

Are you using the align property as shown in screenshot1 or screenshot2? Using the align property as in screenshot1 always works for me but it looks like you used some other alignment procedure.

ngb222 May 27, 2010 11:58 AM

Larry, I started a test post and am doing it from scratch and it seems to be working.
thanks for pointing that out to me.
I had created this in an html program including the images with absolute urls, this usually works fine for me in wordpress, but not with this theme for sure. ( I just use rawhtml plugin all the time.)

lmilesw May 27, 2010 12:10 PM

I'm not sure what you mean by this is an ongoing problem with this theme. I just went into a post, added two images with text after each and then floated the images to the left with no problem and no stair stepping.

Could you post the html for a problem page here or send as a PM so I can take a look?

ngb222 May 27, 2010 12:44 PM

http://greatdeals-bargains.com/links/

Still not working and I just spent yet another hour redoing this!
This is a nightmare, yet again.


All times are GMT -6. The time now is 09:12 PM.

Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.