Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   RSS, Feeds & Subscribing (http://forum.bytesforall.com/forumdisplay.php?f=18)
-   -   [SOLVED] Help needed with Feeds in Sidebar (http://forum.bytesforall.com/showthread.php?t=616)

Shepherd Jim Mar 2, 2009 04:08 PM

[SOLVED] Help needed with Feeds in Sidebar
I have gotten SO confused dealing with Feedburner -- there is nothing intuitive about their website and processes!

I have set up the BFA Subscribe widget at the top of the right sidebar. The RSS icon seems to work okay. A small window pops open and I've been able to subscribe to posts.

AND in that same little popup I'm offered the ability to do an email subscription.

BUT, getting back to the widget: if I click on the commments feed icon I get an error:

FeedBurner could not deliver this feed to you because of the specific problem listed below:
Feed Address: http://feeds.feedburner.com/CommentsForHatchtownFarm
HTTP Error (Code) and Message: (404) Feed not found error: FeedBurner cannot locate this feed URI.

AND, if I click on the email subscription icon (or try to use the "fill in the email address form" I am told:
The feed does not have subscriptions by email enabled
The temporary URL of our site is http://www.hatchtown.com/wp/

I really need someone who understands feeds and Feedburner to look at this and steer me back onto track. Thank you!


PaulG Mar 2, 2009 04:36 PM

I wish I could help but I am having a similar issue with the widget. When filling out the email form I am told
The feed does not have subscriptions by email enabled.

Yet when i click on the email icon i am forwarded to my feedburner form for email.

My url is http://watchmeweigh.com/

Thanks in advance.

Flynn Mar 2, 2009 05:12 PM

in the BFA Subscribe widget, into the field

Feedburner Email ID:

you need to put your ID, a string without spaces that resembles your site name, and not your email address. Below that text fields there's an explanation on how to find your Feedburner "Email" ID.

As for the comments feed. Did you create this feed (it's an extra feed) at Feedburner? When you log in into your Feedburner account, click on "My feeds" on the top left, then you should see "Comments For Hatchtown Farm" listed. Click on it, then click on "Edit feed details" on the top left. What do you have in "Original Feed:" and "Feed Address:"?

Flynn Mar 2, 2009 05:15 PM


are you sure your Feedburner ID is

I think this should be

It seems that the form is just more sensitive that's probably the reason the link is working but the form submission isn't

Shepherd Jim Mar 2, 2009 10:13 PM

Hello Flynn:

Okay! I have the email feed working. It seems I was having the same problem as PaulG = there was that extra "&amp" tacked onto my Feedburner ID. BTW, I found the ID in the second, smaller window not the larger one.
<a href="http://feedburner.google.com/fb/a/mailverify?uri=HatchtownFarm&amp;loc=en_US">Subscribe to Hatchtown Farm by Email</a>
Re the Comments Feeds, I seem to have created "Feed Title: Comments for Hatchtown Farm" with
"Feed Address: http://feeds.feedburner.com/CommentsForHatchtownFarm" but can't seem to figure out how to "find" or "claim" it on the Feedburner site. When I click on "My Feeds" I see just the one main one for "Hatchtown Farm".

Note: there's a good chance that when I originally created my Feedburner account and the feeds that there NO comments on any of the posts. Our website hasn't "gone public" yet -- we've been loading in pre-dated posts. I have since created a few comments in case the lack of comments was the problem re setting up the comment feed.

I think someone should re-think the whole Feedburner thing! There's a Feedburner Google Group but it doesn't look like any Feedburner folks are in there answering any questions.


Shepherd Jim Mar 7, 2009 08:34 AM

Still need HELP!

Okay, I finally managed to get the "Comments Feed" burned and it now shows up in the listing in "My Feeds" at Feedburner = "Comments for Hatchtown Farm".

BUT, if I click on the Comments icon in my header/logo area on http://www.hatchtown.com/wp/ I still get the error:
FeedBurner could not deliver this feed to you because of the specific problem listed below:

Feed Address: http://feeds.feedburner.com/CommentsForHatchtownFarm

HTTP Error (Code) and Message: (404) Feed not found error: FeedBurner cannot locate this feed URI.
I'm pretty sure that I need to update some info in Atahualpa, but I cannot figure out what or where.

Flynn Mar 7, 2009 09:42 AM

Your Feed Address is probably


Note the "2" after http://feeds

Put http://feeds2.feedburner.com/CommentsForHatchtownFarm at Site Admin -> Settings -> Feedburner -> Optional: If you also want to handle your WordPress comments feed using FeedBurner, create a FeedBurner comments feed and then enter its address below:

Shepherd Jim Mar 7, 2009 05:53 PM

Thanks Flynn!

Once again you've pulled my floating div out of the fire. ;) I had the same problem with the missing "2" when setting up the Posts feed. I know I copied and pasted ...has me thinking that maybe when Feedburner first shows you the newly created feed it omits the "2" which then appears later after they've taken the "bubble wrap." as they put it, off the new feed.

I guess I'm done messing with RSS until maybe I try to fiddle around with letting site visitors subscribe to a feed for a single, specific post/comment.

Here in the USA we're putting our clocks ahead an hour this morning at 2am -- going onto DST = daylight savings time. I do not enjoy losing an hour's sleep.

Thanks again!

mikehejt Apr 8, 2009 02:24 PM

...OK...So I am having the same problem. I read this thread 3 times and read the Atahualpa Theme Options -> RSS Settings -> Feedburner ID for this site section at least 3 times.

My Feedburner account seems to be setup correctly. I can manually enter this URL into a browser and get the feedburner email subscription page: http://feedburner.google.com/fb/a/ma...dTYf&loc=en_US...

But when I click through from the WP Atahualpa BPA Email Subscribe Link I get "The feed does not have subscriptions by email enabled". The link is only navigating to "http://feedburner.google.com/fb/a/mailverify". For some reason it is not adding the "?uri=sinarbron/dTYf&loc=en_US" to the end.

I have tried setting the RSS Settings -> Feedburner ID to each of the following values with no luck:
try 1 (just the ID): sinarbron/dTYf
try 2: (just the ID without the /dTYf): sinarbron
try 3 (the whole url): http://feedburner.google.com/fb/a/ma...dTYf&loc=en_US

When I put the whole URL in I get a slightly different error (a NULL error), but still no signup.

Flynn Apr 9, 2009 06:00 AM

Your ID is sinarbron/dTYf

At A. Theme Options -> RSS Settings -> Feedburner ID for this site?
you'd put sinarbron/dTYf

At A. Theme Options -> RSS Settings -> Show Feedburner Email icon?
select Yes

At A. Theme Options -> RSS Settings -> OLD or NEW Feedburner account?
select New - at feedburner.google.com

These settings only apply to the "Subscribe by Email" Text and (small) Button at the top right, in the header area

The Feedburner ID for the BFA subscribe widget (that you can place in a sidebar) would be set inside the widget, not here.

If all this doesn't work:

Do you have a cache running such as WP Super Cache, WP Cache 2?
Do you have a current version of the theme?

samuel29 Aug 27, 2010 12:38 AM

I have tailored my site to look perfect in every browser, but Internet Explorer 6 is wreaking havoc with my sidebar and I can't seem to figure out why. Currently, everything is looking correct, but the emailsignup box and the socialnetworks boxes are somehow being extended too big on the right side causing the whole sidebar to drop below the rest of the content.

__________________________________________________ _____________-
Earn an Extra $1000 to $1200 per month doing Part Time Data Entry Jobs! Work from home data entry jobs to post simple data submissions on Internet. Make $1 per entry. Easy form filling, data entry and ad posting jobs. No selling, No phone calls, No Marketing. No Investment. Bi-weekly payments. Full Training Provided.*Pls visit:**Data-Entry*

SocJusticeUSA May 17, 2011 12:17 PM

I, too, am getting the message: "The feed does not have subscriptions by email enabled" when attempting to subscribe by email to my site's feed.


I have copied and pasted the feedburner code into my "home" page, I have activated email subscriptions in feedburner, I have pasted my ID into the theme options (SocialJusticeUSA), and I have pasted my working feed address into the FeedSmith Options (http://feeds.feedburner.com/SocialJusticeUSA).

Not sure what I'm missing...

Thanks for any help.

lmilesw May 17, 2011 01:01 PM

What do you mean by "I have copied and pasted the feedburner code into my "home" page"?

SocJusticeUSA May 18, 2011 04:05 PM

I used the "form" code provided by feedburner to insert an email subscription form into my site's homepage. You can see it here (bottom left):


But when anyone tries to submit their address, they get the message that says email subs haven't been setup for the feed...

lmilesw May 18, 2011 04:17 PM

I would double check all your setting and especially the setup for email subs in your Feedburner Account. Especially check the setting indicated in this screenshot.

SocJusticeUSA May 18, 2011 04:31 PM

Yeah, that's definitely active.

Could it be that the Atahualpa RSS settings are assuming its in the header when I'm trying to have it within a "page"...?

lmilesw May 18, 2011 04:36 PM

I would either look for a plugin that allows you to put a shortcode in a page or you could perhaps use this plugin to put a widget on a page.

SocJusticeUSA May 18, 2011 05:41 PM

I've used the "Widgets on Pages" plugin, which has fixed the subscription issue (thanks!), but I'm now having trouble with the formatting.


How to remove the little black dot, the faint blue bar above the form box, and how to change the form box width so it fits in the space properly...?

lmilesw May 18, 2011 06:40 PM

I just fiddled with Firebug for a bit and came up with this CSS you can add to ATO>Add HTML/CSS Inserts>CSS Inserts which may do the trick for you.
HTML Code:

#Widgets_on_Pages_1 ul {
    padding-left: 5px !important;
    list-style: none;
div.post table tr.alt td {
    background: transparent !important;

SocJusticeUSA May 18, 2011 10:22 PM

Thank you SO much! It's finally just right. So appreciate your help and speed of reply! :)

All times are GMT -6. The time now is 12:51 AM.

Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.