Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Atahualpa 3 Wordpress theme (http://forum.bytesforall.com/forumdisplay.php?f=2)
-   -   [SOLVED] Link to list of posts in category or archive (http://forum.bytesforall.com/showthread.php?t=154)

JKauffman Jan 31, 2009 08:59 PM

[SOLVED] Link to list of posts in category or archive
 
I'm sorry if this is a known issue. I tried searching the existing threads, but I could have missed it (I may be in over my head).

The theme looks great, but I've got one problem. I use the WP archive and category sidebar widgets. When I activate Atahulalpa v3(.1.8? - the most recent one anyway) and try to pull up a list of posts from either (a category or a month) I get the following error message:

"Fatal error: Call to undefined function: is_last_post() in ... /wp-content/themes/atahualpa/archive.php on line 32"

JKauffman Jan 31, 2009 10:12 PM

I should have tried this first. I downloaded a fresh copy of the theme directly from your site (rather than the theme directory at WordPress) and uploaded it to my site. It works fine now.

I wonder if I got a bad copy or if I broke it somehow?

Flynn Feb 1, 2009 08:14 AM

That's weird, you should not even have an "archive.php" (that existed in Atahualpa 2 but not anymore in Atahualpa 3) and the path should be /atahualpa3/ instead of /atahualpa/.

Edit: Just downloaded the WP version: Looks like Wordpress changed the folder name from atahualpa3 to atahualpa. Hmmmm...

Now I know what happened: When you uploaded the version from Wordpress.org, you got a /atahualpa/ directory and when uploading that the already existing "/atahualpa/archive.php" (from version 2.x) on your web server was not overwritten.

The version from my site is in a folder named /atahualpa3/ as intended by me and lives side by side with a possibly existing /atahualpa/ (= version 2.x) on the web server.

Since Wordpress (as a software) always looks for an archive.php first when serving an archive page, it processed that archive.php (which should not have been there at all, in v. 3.x)

Thank you, I think this helps me with another mysterious problem a user has. I will see if I can clear this with Wordpress on Monday.


All times are GMT -6. The time now is 12:43 PM.

Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.