Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Center area post/pages (http://forum.bytesforall.com/forumdisplay.php?f=32)
-   -   [SOLVED] Text Link To A File (http://forum.bytesforall.com/showthread.php?t=5875)

ChrisPanimation Feb 13, 2010 11:49 PM

[SOLVED] Text Link To A File
 
Hey guys,
This seems like it should be straight forward but I'm not seeing how to do this - and can't find it in search...

How do I make a text link to a file. I want my visitors to be able to click on a text link so that they can download a file. (I don't want to link to a URL - but rather a file sitting in my ftp which can be downloaded by the visitor).

I'd like to do this in the center area in one of my pages.

Chris

juggledad Feb 14, 2010 05:46 AM

<a href="ftp://yourdomain.com/filelocation/filetodownload.txt">Download file</a>

ChrisPanimation Feb 14, 2010 08:15 AM

Thanks JD, I'll try that right now.

ChrisPanimation Feb 14, 2010 08:49 AM

Like this?

<a href="ftp://animcareerpro.com/blog/wp-content/themes/atahualpa/Flash_Workshop1_Ex.A.fla" >TestLink</a>

Note:
The file I want for download is: Flash_Workshop1_Ex.A.fla


Windows gave me this error message when I tried to download it from my site.
C:\Users\Chris\Desktop\Flash_Workshop1_Ex.A.fla could not be saved, because the source file could not be read.
This is if I right click and go - "save link as"

If I just click on the link it times out.

Here's my site if you want to test it animcareerpro.com/blog - In the "Training Exercises" page.

juggledad Feb 14, 2010 10:39 AM

It may have to do with the multiple '.' in the file name. why don't you zip the file

ChrisPanimation Feb 14, 2010 11:16 PM

Ok, I got rid to the "." and ziped it but that's not working. I'm getting the same message - been fussing with it for hours - any suggestions. I'm still working on it here...

<a href="ftp://animcareerpro.com/blog/wp-content/themes/atahualpa/Flash_Workshop1_ExerciseA.zip">TestLink</a>

juggledad Feb 15, 2010 05:34 AM

Chris try this, get rid of the leading 'ftp://'

ChrisPanimation Feb 15, 2010 09:56 PM

That worked - you have to right click and "save link as" but it downloads....so I did a test and downloaded the file, but the files are corrupt after being downloaded. They do open no problem from my local drive.

That's probably out of your juristiction of advise...I don't know if this has anything to do with Atahualpa.

juggledad Feb 16, 2010 04:55 AM

Try a TEXT file. you may be running into a translation issue. Zip your file and try that too.

ChrisPanimation Feb 18, 2010 09:13 PM

I got it. It just had to start like this...

<a href="http://

cheers!


All times are GMT -6. The time now is 05:23 AM.

Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.