Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   New Versions, & Updating (http://forum.bytesforall.com/forumdisplay.php?f=12)
-   -   Problem with updating (http://forum.bytesforall.com/showthread.php?t=9741)

inkdork Sep 18, 2010 05:16 AM

Problem with updating
 
I had version 3.4.9, and was loving it. Just redid everything, had it perfect. Found out tonight it wasn't the current version, so I uploaded the newest release into my themes directory- I did not overwrite the old version.

When I activated it, it was fine. I uploaded my settings I had just exported, and got this error:

Warning: Invalid argument supplied for foreach() in /home/content/b/o/e/boerbabe21/html/wp-content/themes/atahualpa/functions.php on line 59

Fatal error: Cannot use string offset as an array in /home/content/b/o/e/boerbabe21/html/wp-content/themes/atahualpa/functions/bfa_get_options.php on line 452

in place of my blog displaying.

I tried to switch back to my older version, and I got the same error. No blog.

I deleted both versions completely, and re-uploaded the older one. Same error.

How do I fix this? And what did I do to cause this problem? :confused:

inkdork Sep 18, 2010 05:24 AM

Clarification-

The newer version says

Warning: Invalid argument supplied for foreach() in /home/content/b/o/e/boerbabe21/html/wp-content/themes/atahualpa353/functions.php on line 59

Fatal error: Cannot use string offset as an array in /home/content/b/o/e/boerbabe21/html/wp-content/themes/atahualpa353/functions/bfa_get_options.php on line 452

The older one just says as I put in the first posting.

inkdork Sep 18, 2010 05:36 AM

Strangest thing- I imported my settings to the older version just as I had downloaded them, and now the older version works fine.

I'm still curious as to what happened there, but for now, things appear to be up and working fine.

Guess I won't be updating anytime soon unless I copy down all my mods and paste them in one at a time.

juggledad Sep 18, 2010 08:04 AM

1) when you upgrade the theme from 3.4.9 to 3.5.3, you don't have to re-import the theme settings. They are stored in the database and should just show up. (It is a good idea to do backups before making any major change - like an upgrade - I suggest backuping the database)

2) The format the import/export settings were stored in changed in 3.5.2
Quote:

- Export/Import system now uses the JSON format instead of the serialized/base64_encode format used in 3.5.1
- The reason for the change is that Wordpress.org won't list the base64_ version due to the malicious things often done with base64. Sorry I should have thought about that. base64 encoding the settings files seemed to be a quick fix for the issues many users had with the settings files.
- Unfortunately this means that if you exported a settings file in 3.5.1 and want to import that in 3.5.2, you'd need to do some legwork: Download this zip file, extract it, rename the "uploadBASE64.php" to "upload.php" and replace the existing "upload.php" in Atahualpa 3.5.2 with it.
- If you don't have old settings files that you want to import then you don't need to do the steps described above

inkdork Sep 18, 2010 08:56 PM

Okay, not quite sure if I am understanding this right.

When I initially uploaded the new version of the theme, and activated it, it looked like it does by default. The plant (I think) image in the header, semi-opaque edges, everything just like it is new out of the box.

I would have to go through the steps illustrated above in your quoted text (I saw the original post with the links elsewhere, so can go find them easy enough) and then import my settings to the new version? Or is there some other way? Not quite following.

juggledad Sep 19, 2010 05:19 AM

Try disabling any caching plugging and cleaning out the caches


All times are GMT -6. The time now is 08:58 PM.

Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.