Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Header configuration & styling (http://forum.bytesforall.com/forumdisplay.php?f=15)
-   -   [SOLVED] static page <title> with WP setting "Front page displays: Your latest posts" (http://forum.bytesforall.com/showthread.php?t=14490)

jgehrcke Jun 4, 2011 07:44 AM

[SOLVED] static page <title> with WP setting "Front page displays: Your latest posts"
 
Dear supporters,

on my website http://gehrcke.de, I've set Wordpress Dashboard->Settings->Reading to "Front page displays: Your latest posts".

The problem now is that the HTML <title> tag of this front page always carries the title of the most recent blog post. Instead, I would like to define my own static title for this front page and, if possible, meta tags. How do I accomplish this?

I currently use Atahualpa 3.6.7.

Thanks a lot in advance, I've tried to solve this issue for a long time now and the same question in the WordPress forum did not yield a solution.

Jan-Philip

lmilesw Jun 4, 2011 07:53 PM

That's where an SEO plugin would come in handy.

jgehrcke Jun 5, 2011 04:38 AM

Thanks for your answer.

First, I do not see any reason, why this should not work without SEO plugin. My feeling is, that people intuitively want to have the frontpage showing the blog posts while having a static title like "Peter's blog".

So, primarily I am looking for a way to achieve this with only WordPress/Atahualpa and I'm still happy to get suggestions at this point.

Then, of course, you are right. I also thought, that SEO plugins should be able to to this. I tried "TGFI.net SEO" and "SEO Title Tag". Both do not have an option to set the tags for the "front page". Do you know which SEO plugin can do what I want?

juggledad Jun 5, 2011 04:46 AM

make sure you have applied ALL the 3.6.7 BUGFIX's (New Versions & Updates forum)

it works the way you expect for me with no SEO

jgehrcke Jun 7, 2011 07:04 AM

juggledead,

you are totally right, thank you. The TGFI SEO plugin had screwed this up. Without any SEO plugin, Atahualpa is showing the title as defined in WP Settings -> General -> Site title on the blog post front page; great.

With the plugin "All in one SEO", I was able to additionally set the keywords and description meta tags for the front page. I deactivated any title-blabla of all in one SEO, because Atahualpa already does a good job at this point.

I should have done this standard procedure myself... deactivating relevant plugins and see how it works out. Sorry that I've taken your time :)

Jan-Philip


All times are GMT -6. The time now is 09:09 PM.

Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.