Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Header configuration & styling (http://forum.bytesforall.com/forumdisplay.php?f=15)
-   -   Ata Themes Option Screen disfigured (http://forum.bytesforall.com/showthread.php?t=7440)

qbuster Jun 5, 2010 01:15 AM

Ata Themes Option Screen disfigured
 
2 Attachment(s)
I'm running Ata 3.5.1 with Buddypress Template Pack 1.2.4 and am experiencing a garbled Ata Theme Options screen (under Appearances), I have attached a couple of screen images. The site, http://waterwaywatch.org, is running on a Linux shared server on a remote host.

As you can see from the attached image Ata_config.jpg, foreground (text) appears to be set at #ffffff instead of #000000 with the consequence that the main text is difficult to read and the examples impossible.

The second image ata_footer.jpg shows that the contents have been pushed down and the bottom part is obscured by the the footer.

This appears to be related to css instructions being loaded. When the screen first appears it is normal then, if watching with Firebug, one can see load-styles.php pulling in additional settings from somewhere and the screen garbles.

I have tried re-setting the configs, importing previous versions and deleting bta_ata4. Any ideas short of wiping the whole lot?

Cheers


Will

juggledad Jun 5, 2010 04:17 AM

have you tried disabling all plugins

paulae Jun 5, 2010 06:11 AM

I had trouble with the Buddypress Template pack too, although I was not working with Ata 3.5.1 at the time. I can't even recall now what the problem was, but I'll bet it's not playing well with the theme. Which version of WP are you running?

qbuster Jun 5, 2010 06:15 AM

Quote:

Originally Posted by juggledad (Post 33650)
have you tried disabling all plugins

Just completed that forensic exercise - I had around 20 plugins active and suspected Buddypress Template Pack 1.2.4. I all non-Buddypress plugins and checked the state of Ata Them Options each time.

When they all non-BP plugins were inactive, I then closed BP Template Pack and Ata Theme Options recovered immediately. I them switched all the non-BP plugins back on and Ata Theme Options remained stable. So you were spot-on juggledad!

I will now do a detailed comparison of bp.css (from the BP Template pack), default.css (of BP Default plugin), and atahualpa style.css to see if I can spot the problem.

Thanks for the tip....

Cheers


Will

qbuster Jun 5, 2010 09:58 AM

Quote:

Originally Posted by paulae (Post 33654)
I had trouble with the Buddypress Template pack too, although I was not working with Ata 3.5.1 at the time. I can't even recall now what the problem was, but I'll bet it's not playing well with the theme. Which version of WP are you running?

I'm using WP 2.9.2. I also tried Wp-mu and the beta of WP 3.0 but decided it would be easier to use 2.9.2 whilst WP 3 was in beta.

Is your Ata/BP up and running now? I'm getting close although I would like to get the Groups and Members sections looking more like Ata than BP.

Regards


Will

paulae Jun 5, 2010 10:28 AM

WP 3.0 is in Release Candidate 1 stage, so you might want to try it since MU is in the core now. They call it "multi-site" now, and you'll see "network" in your admin dashboard.

I know Buddypress Template pack is supposed to help any theme be MU/network friendly, but I'm not sure it really plays well with Atahualpa yet. When I was using MU with WP 2.9.2, I used a Buddypress theme as my home area, but made many themes, including Atahualpa, available to members for their own sites within the MU network.

I'm in the process of learning how to convert from the old MU to the new system.

qbuster Jun 5, 2010 12:33 PM

Quote:

Originally Posted by paulae (Post 33660)
WP 3.0 is in Release Candidate 1 stage, so you might want to try it since MU is in the core now. They call it "multi-site" now, and you'll see "network" in your admin dashboard.

My interest in Buddypress is the facebook-like groups feature. I note that the founder of BuddyPress is now a full time developer with Wordpress - are BP features now built into WP 3.0?


Quote:

I know Buddypress Template pack is supposed to help any theme be MU/network friendly, but I'm not sure it really plays well with Atahualpa yet. When I was using MU with WP 2.9.2, I used a Buddypress theme as my home area, but made many themes, including Atahualpa, available to members for their own sites within the MU network.

I'm in the process of learning how to convert from the old MU to the new system.
The BP Template pack does seem to enforce too many CSS rules upon Ata - I'm attempting to isolate some of the better rules and put them into a child theme.

Have you any urls I could take a look at?

Cheers


Will

gcaleval Jun 6, 2010 01:30 PM

Quote:

Originally Posted by paulae (Post 33660)
When I was using MU with WP 2.9.2, I used a Buddypress theme as my home area, but made many themes, including Atahualpa, available to members for their own sites within the MU network.

I'm in the process of learning how to convert from the old MU to the new system.

That is the recommended approach. But for some of us, the "blog content" is a core value of the site, with the social networking functionality of BP building a community around that content. So for me it has to be ATA as the parent theme because I want that content to be the first thing users see and use.

The BP-enabled themes are too restrictive for non-coders. I've seen several examples where there have been very nice edits of the BP theme, but they all still have the same visual structure. Great big banner picture and box content. The best ones require pretty advanced skills with CSS and theme editing to achieve.

I relate this only to underscore how important it is to some of us to get ATA working as the primary theme.

Of course it is likely the very flexibility and power of ATA that makes it easier to create conflicts.

As to the theme pack, I had no conflicts until 3.51. It was a very simple matter of wrapping the BP php pages with get-all-options header call replacing the plain get-header call. That no longer is working.

FWIW I did have lots of BP conflicts with other plugins and still am trying to resolve the challenges of registration plugins. Forget about Wishlist Member, they'll happily take your money and then provide the support response of "We don't use BP so can't help you." S2Member works great on the BP side, but is inflexible overall, covering only situations where content access becomes an all-or-nothing proposition. Role Scoper broke a bunch of stuff. So my weary struggle has been directed at all that and only now am I back to square one on the template packs functionality <sigh> and <laugh>.

The cleanest solution would be to split the sites in two, but I would absolutely have to have a shared login and the discussions I found about shared WP logins on the web have all left me more afraid of that plunge than continuing the current swim upstream.


All times are GMT -6. The time now is 11:35 AM.

Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.