Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Atahualpa 3 Wordpress theme (http://forum.bytesforall.com/forumdisplay.php?f=2)
-   -   [SOLVED] Font size not working (http://forum.bytesforall.com/showthread.php?t=2031)

pushkinpassey Jun 12, 2009 10:20 PM

[SOLVED] Font size not working
 
Hi Flynn,
I have searched extensively through the forum, and I am unable to change the font size of my text.
My setting for Body, Text, Links >> Body style is:
Code:

font-family: arial, sans-serif; line-height: 20pt; font-size: 10pt;
Please help!

Cheers!

juggledad Jun 13, 2009 02:57 AM

There are many places that text occurs, Blog title, widgets, post headers, post text. and many places in the options to set them. Which set of text are you having a problem with?

posting your url so the problem can be seen is also helpful

pushkinpassey Jun 13, 2009 04:59 AM

Hi!
I was talking about the body text in the page (center column). The URL is:
http://sed.aaschool.ac.uk/

Cheers!

juggledad Jun 13, 2009 08:55 AM

The center column (the posts) are styled in the ATO-> Post/Page Styling. Each section of a post can be styled differently, so you could have one font family for the kicker, another for the headline etc, etc.

pushkinpassey Jun 13, 2009 09:14 AM

hi Juggledad, I followed your suggestion and added the following line in the 'BODY Box' on Post/Page styling:
Code:

font-size: 3.5em;
and tried it with
Code:

font-size: 24px;
as well.... but it's still not reflecting in any pages.

juggledad Jun 13, 2009 08:05 PM

The url you is invalid, please check the spelling

fromtheranks Jun 15, 2009 01:15 PM

Pushkinpassey,

If I may step in here ...

What version of Atahualpa are you on? I'm using 3.3.3 and what you've shown in your first example (3.5em) works for me. To make sure I just re-tested, changing ranges from 0.8em to 3.5em, and doing so created some "interesting" results in the Headlines of both posts and pages (even the tagcloud page I added by creating a separate php file: tagcloud.php).

If you're on 3.3.3 here are some possible suggestions (based on mistakes I've made):

1. look for a missing semi-colon(s) somewhere in your settings

2. look for the font-size argument having been entered as font.size (using a period instead of a dash caused me to go as far as resetting the Post/Page Styling page entirely and then redoing the settings ... which is how and when I caught the typo)

3. if it was working before and you added something, like a plugin, or changed something else, back out the addition or change and re-test.

Also, note the difference between "Post/Page Styling --> Headline Box: Text" and "Post/Page Styling --> Headline Box: Links". The difference is subtle -- I missed it the first time around.

Hope this helps.

pushkinpassey Jun 15, 2009 01:28 PM

Hi fromtheranks!
Thanks for your suggestions, but I am still having the same problem!
I am using 3.3.3 only.

In the 'Body, texts & links' page, 'Body style' has the following entered in the box.
Code:

font-family: arial, sans-serif; line-height: 20pt; font-size: 3.5em;
If I change the font face, the change is reflected, but not if I change the font size!

I even tried putting font-face: 3.5em in 'BODY Box' on the Post/Page styling section, even though the description states 'Style the box that contains the post/page main text (= the "body copy"). The text and links in the post/page main text box can be styled on the main tab "Text & Link Styling".', but it didn't work!

Please help!
Pushkin

juggledad Jun 15, 2009 02:16 PM

What's the url, the one you previously posted is invalid.

pushkinpassey Jun 15, 2009 02:19 PM

Hi! I recently changed the DNS settings, and the new settings haven't propagated well enough yet.
If you add the following in ur hosts file (in C:\Windows\System32\drivers\etc), it will work:
Code:

91.102.64.136  sed.aaschool.ac.uk
Cheers!

juggledad Jun 15, 2009 02:47 PM

Hmmm, when I use the ip address I end up at the Parallels Plesk control panel (I'm on a MAC)
---
update - found the hosts on teh mac, made the change and got to the site. now to start looking...

just to let you know when I copy your settings to my Body Style, much of the text get huge, so there must be some other settings you have (which is why I want to look at the generated source of a page)

juggledad Jun 15, 2009 03:32 PM

Hi, found the problem, it looks like you have a second 'font-size' in the body style that is overriding teh 'font-size: 3.5em' you are entering. Do this
1) go to Body Style (ATO->Body, Text & Links)
2) put your cursor in teh block where the styles go
3) do a select all and a copy
4) switch to wordpad and do a paste
What do you see? Does it look like this:
HTML Code:

        font-family: arial, sans-serif; line-height: 20pt; font-size: 3.5em;

font-size: 0.8em;
color: #ffffff;
background: #1F1F1F;

If so delete the extra font-size and past it back in body style

If not do the following
1) Make note of each option you have set in the ATO->Body, Text & Links
2) at the bottom of the page, press the RED 'Reset Settings' button.
3) add your settings back in from the notes in step (1).
4) Go visit the web site
I think this should fix the problem, if not let me knopw and we will dig deeper.

pushkinpassey Jun 15, 2009 03:38 PM

There was an override! Thanks a lot Juggledad! It's fixed now!


All times are GMT -6. The time now is 02:25 AM.

Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.