Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Sidebars & Widgets (http://forum.bytesforall.com/forumdisplay.php?f=14)
-   -   [SOLVED] Image in text widget is repeating? (http://forum.bytesforall.com/showthread.php?t=15088)

49Monsters Aug 11, 2011 03:47 PM

[SOLVED] Image in text widget is repeating?
 
Hi folks, been away from wordpress and the theme for a long time. Looked at my "for fun" site the other day and have some problems text widget in the sidebar.

Site is : 49monsters.com

You can see one image on the right and one on the left are showing up three time? I have changed nothing.

I'm on WordPress 3.21, ATA 3.5.3

Thaks for the help.
Guy

juggledad Aug 11, 2011 04:32 PM

(love the cartoons)

very odd, I see the multiple images in Safari but not in FireFox

what browser are you using?

49Monsters Aug 11, 2011 05:26 PM

Hey JD,
I see them in both Safari and Firefox.

lmilesw Aug 11, 2011 08:05 PM

How did you place those images there? In a widget? With what code?

49Monsters Aug 11, 2011 09:04 PM

In a Text widget. They worked fine for months. Then all the sudden they started showing three. Started a couple weeks ago I believe.

Here is the code for the right side bar:

Code in text widget:
Code:

<a id="Point_monster" </a>
Code in ATO, HTML/CSS insert:
Code:

/*---------------- POINT_MONSTER CSS - START --------------*/
#Point_monster
{
z-index: 4; position: relative; float: left; width: auto;
margin-right: 0px;
margin-left: 0px;
margin-top: 70px;
  display: block;
  width: 150px;
  height: 203px;
  background: url("./wp-content/themes/atahualpa353/images/Point_monster.png") no-repeat 0 0;
}

#Point_monster:hover
{
  background-position: 0 -203px;
}

#Point_monster span
{
  display: none;
}
/*------------------------------------------------------------*/


49Monsters Aug 11, 2011 09:15 PM

I did a little investigating and ran into this...

The "LEFT" sidebar has five images (the pencil sketches)

Code:

<a id="Smile" </a>

<a id="Thumb" </a>

<a id="Slug" </a>

<a id="Bomb" </a>

<a id="Goose_1" </a>

Right now, Goose_1 is last and it shows three times. If I delete it, then Bomb shows three. Whichever image is last will repeat.

lmilesw Aug 11, 2011 10:11 PM

It would seem like the code should be
HTML Code:

<a id="Smile"></a>
or
HTML Code:

<div id="Smile"></div>
There is no close the the opening <a

49Monsters Aug 12, 2011 05:46 AM

I deleted the <a/... no change.

juggledad Aug 12, 2011 05:51 AM

what version of the browsers are you using?

49Monsters Aug 12, 2011 06:00 AM

Safari 5.1

FireFox 5.01

Mac OS 10.6.8

49Monsters Aug 12, 2011 06:14 AM

When I look at it in Firebug, it shows:

Code:

<div id="text-6" class="widget widget_text">
<div class="textwidget">
<a id="Point_monster"></a>
</div>
<a id="Point_monster"> </a>
</div>
<a id="Point_monster"> </a>


juggledad Aug 12, 2011 06:44 AM

go look at your text widget, you don't have the closing </a>
HTML Code:

<!-- Right Sidebar -->
<td id="right">
        <div id="text-6" class="widget widget_text">                       
                <div class="textwidget">
                    <a id="Point_monster" >            <======== no </a> it should be here
                </div>
        </div>
</td>
<!-- / Right Sidebar -->

(edited to make it readable

lmilesw Aug 12, 2011 07:00 AM

There was a typo in my post number 7 and may have caused confusion. I didn't have the </a> within the code box. Sorry.

49Monsters Aug 12, 2011 07:23 AM

YEP!
That did it!
Thanks Guys.


All times are GMT -6. The time now is 01:39 PM.

Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.