Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Sidebars & Widgets (http://forum.bytesforall.com/forumdisplay.php?f=14)
-   -   [SOLVED] Display left sidebar in one post only (http://forum.bytesforall.com/showthread.php?t=9528)

bigliettaio Sep 9, 2010 07:01 PM

[SOLVED] Display left sidebar in one post only
 
Atahualpa 3.4.4

There is the way to display a sidebar ( in my case left side bar) in one post only?

Thanks

lmilesw Sep 9, 2010 09:06 PM

If you put all the posts except the one you want the sidebar to show up on in a particular category you could set the sidebars not to show on that category in ATO>Style & configure sidebars.

bigliettaio Sep 10, 2010 04:39 AM

Hi Larry,
i knew that, the problem is that the i pubblished so many posts that list showl be so lenght....BUT after opening that thread i thought that i could simple add
!is_single(ID)
to the widget shown in the right side bar of category who the new post belong to
to display a sort of "new sidebar" and put the content i would like to shown only in that post.
Otherwise i could create a new category to eliminate easily the logic wigdet option and add a new content on my right sidebar
ANYWAY
if it exist a way to show a sidebar in one post only tell me please!

lmilesw Sep 10, 2010 12:08 PM

I have used the Page Sidebars plugin to do something like you are trying. It is a bit old but still works for me.

bigliettaio Sep 10, 2010 03:35 PM

Well done Larry,
i think it could be the one i' m gonna looking for.
But do you think it workk properly with wp 2.8.4?
In which version you upoload it?
Anyway i' m gonna to upload and used it.

Thanks for the suggestion.

lmilesw Sep 10, 2010 10:22 PM

It should work fine with 2.8.4

juggledad Sep 11, 2010 08:12 PM

I would upgrade to at least WP 2.9.2 because of the security holes in earlier releases.

bigliettaio Sep 12, 2010 03:45 PM

Hi JD,
thanks.

ole@oleaustin.com Oct 23, 2010 11:20 AM

I can't seem to figure out how to start a new thread in the Forum, so I'm going to tack on here. My blog posts show up like there's an inner sidebar to the left. See http://oleaustin.com/latest-news/. I've searched but can't seem to find the place where the solution might be hiding. Any tips? Thanks! - Ole

lmilesw Oct 23, 2010 11:32 AM

Go to ATO>Configure Sidebars and uncheck all the boxes next to "LEFT INNER sidebar: Don't display on Pages:"

Also to start a new thread go to the home page and click on one of the forums such as "Sidebar and Widgets". At the top you should now see a "New Thread" button.

ole@oleaustin.com Oct 23, 2010 12:22 PM

Worked! (Been wondering about that for MONTHS). Thank you again!!!!!


All times are GMT -6. The time now is 01:26 PM.

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.