Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Sidebars & Widgets (http://forum.bytesforall.com/forumdisplay.php?f=14)
-   -   [SOLVED] Simple Text Widget Fails (http://forum.bytesforall.com/showthread.php?t=16064)

Alvin Nov 22, 2011 06:45 PM

[SOLVED] Simple Text Widget Fails
 
I'm using the 3.7.1 and want to display a banner ad in the left side bar.
Javascript didn't work and html code didn't work. It seems to be there in the sidebar because the other widget shifted down.

How can I get ads to display in the sidebar widget?

Website http://mostpopularjewelry.com

Thanks, Alvin

lmilesw Nov 22, 2011 10:10 PM

You may have to use an "advanced" text widget such as Linkable Title Html and Php Widget.

Alvin Nov 23, 2011 09:50 AM

Okay thanks, I will give it a try

Alvin Nov 23, 2011 10:37 AM

Alright I tried that and two other advanced text widgets besides (Advanced Text Widget and Black Studio TinyMCE) and the most I could get to display is the clickable title with the Linkable Title Html and PHP widget. None of the content in the body will show.

I noticed that when I tried the Black Studio TinyMCE widget that when I saved the code in html version it was there. But when I switched to visual the banner flashed for one second then vanished.

I'm pretty convinced the theme is preventing the sidebar widgets from showing content.
Most Popular Jewelry

juggledad Nov 23, 2011 10:58 AM

Quote:

I'm pretty convinced the theme is preventing the sidebar widgets from showing content.
temporally switch to twenty-eleven and see if you can get the widget to work. this will tell if it is a theme issue or not

Alvin Nov 23, 2011 11:15 AM

Text link will show but no image...

juggledad Nov 23, 2011 11:20 AM

I don't see a sidear is it on another page?

Alvin Nov 23, 2011 11:32 PM

You must have caught my site when I was testing other themes. The twenty eleven theme didn't want to show any sidebars so I tried another theme I have. It didn't show any banner in the sidebar.

So I tried the banner in the regular page post. It didn't show. So then I copied the banner image to my media library and hyper-linked it with my affiliate link. That worked so I figure there is something preventing my site from pulling media from an external url.

I don't know what else to think so I will live with that for now.

Alvin Nov 25, 2011 03:21 PM

If anyone has an idea how I can get banner code to show a banner in my sidebar using a good plugin or widget, please let me know.

I am just copying the image and hyper-linking it right now.

juggledad Nov 25, 2011 03:30 PM

what banner code are you trying to use?

lmilesw Nov 25, 2011 03:54 PM

html and javascript should be able to be run in some widgets. Can you post a sample of the code you are using so we can test?

Alvin Nov 25, 2011 08:36 PM

1 Attachment(s)
Quote:

Originally Posted by lmilesw (Post 76515)
html and javascript should be able to be run in some widgets. Can you post a sample of the code you are using so we can test?

Yes Here it is

lmilesw Nov 25, 2011 08:56 PM

Other than the size those codes work fine in the standard text widget.

Alvin Nov 26, 2011 10:30 AM

What could the problem be if it doesn't work in mine?

juggledad Nov 26, 2011 10:32 AM

Put it in a text widget and let us know when it's there

Alvin Nov 26, 2011 11:10 AM

Okay thanks for helping,

I have two different widgets now with two different banner code inserted in the left sidebar. I gave them titles so you can see where they are. Without titles they show nothing like before.

juggledad Nov 26, 2011 11:49 AM

1 Attachment(s)
You mean these?
Attachment 1642
so what is the issue?

Alvin Nov 26, 2011 12:45 PM

That was one I had tried. It never showed on my site either. The two I have posted right now are on the bottom left sidebar. Only the titles appear. I am using two different widgets here, the text widget and one called Black Studio TinyMCE that has a wysiwyg editor with html and visual mode.

I even tried to put <code></code> around the html. Still nothing showing.

The titles are in the left sidebar.
SWAROVSKI CRYSTALLIZED

Gemstone Jewelry

Alvin Nov 26, 2011 12:54 PM

1 Attachment(s)
This is what I see

Alvin Nov 26, 2011 01:00 PM

Okay I just checked it with InternetExplorer and it does show. I have been using FireFox all along and it doesn't show. Maybe it's a problem with my FireFox browser?

Alvin Nov 26, 2011 01:17 PM

Aahh yes, I figured it out. I had an ad blocker plugin on my FireFox browser. It works good... So I disabled it and low and behold, there my banners are.

Consider this issue solved.

Thanks for the help guys.


All times are GMT -6. The time now is 05:14 AM.

Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.