Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Excerpts, Read more, Pagination (http://forum.bytesforall.com/forumdisplay.php?f=20)
-   -   [SOLVED] Read More Option taking user to the middle of the post (http://forum.bytesforall.com/showthread.php?t=5600)

djrishi Jan 30, 2010 08:01 AM

[SOLVED] Read More Option taking user to the middle of the post
 
Hi – I am using Atahualpa 3.4.4 & facing a problem with read more option…

When I click on the Read More option (continue reading…) option its takes user to
http://www.haircareresources.com/blo...yles/#more-142

However, it should go to
http://www.haircareresources.com/blo...ut-hairstyles/ only.

I am not worried from SEO perspective as canonical url is working fine however the first url takes you to middle of the post rather than to top of the post.

How can I fix this ? Any solution ????

juggledad Jan 30, 2010 01:06 PM

how are you creating your read more? Are you using a plugin?

djrishi Jan 31, 2010 04:27 AM

Quote:

Originally Posted by juggledad (Post 24254)
how are you creating your read more? Are you using a plugin?

I am using the default "Insert More Tag" Option and not using any plugin..

Thanks

pakacil Jan 31, 2010 05:41 AM

djrishi & juggledad,

i think, it's about how WP works
it's not taking user to the middle of the post, but taking user/reader to the rest of article, start on the next paragraph after we put read-more tag.

then i tried to do this...
open and edit post-template.php file (located in wp-includes directory)
find this code line (about line 219)
PHP Code:

$output .= apply_filters'the_content_more_link'' <a href="' get_permalink() . "#more-$id\" class=\"more-link\">$more_link_text</a>"$more_link_text ); 

and replace or change it to...
PHP Code:

$output .= apply_filters'the_content_more_link'' <a href="' get_permalink() . "\" class=\"more-link\">$more_link_text</a>"$more_link_text ); 

or i just simply del the #more-$id code

read-more link works like what djrishi wants or just like an ordinary permalink ...
CMIW
____
• remember to back-up the original file before change or edit it
• tried with WP 2.9.1 and Ata 3.4.5.1

djrishi Feb 1, 2010 09:54 AM

Quote:

Originally Posted by pakacil (Post 24313)
djrishi & juggledad,

i think, it's about how WP works
it's not taking user to the middle of the post, but taking user/reader to the rest of article, start on the next paragraph after we put read-more tag.

then i tried to do this...
open and edit post-template.php file (located in wp-includes directory)
find this code line (about line 219)
PHP Code:

$output .= apply_filters'the_content_more_link'' <a href="' get_permalink() . "#more-$id\" class=\"more-link\">$more_link_text</a>"$more_link_text ); 

and replace or change it to...
PHP Code:

$output .= apply_filters'the_content_more_link'' <a href="' get_permalink() . "\" class=\"more-link\">$more_link_text</a>"$more_link_text ); 

or i just simply del the #more-$id code

read-more link works like what djrishi wants or just like an ordinary permalink ...
CMIW
____
• remember to back-up the original file before change or edit it
• tried with WP 2.9.1 and Ata 3.4.5.1

Thanks buddy... Working fine... :)


All times are GMT -6. The time now is 12:11 PM.

Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.