Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   New Versions, & Updating (http://forum.bytesforall.com/forumdisplay.php?f=12)
-   -   After updating server site is - well - broken... (http://forum.bytesforall.com/showthread.php?t=12560)

pgtaboada Jan 31, 2011 08:20 PM

After updating server site is - well - broken...
Hi there,

We just updated plesk our server and after that atahualpa stopped working.

Here is my broken blog: http://pgt.de/

=> left and right sidebars are showing up, content area is empty.

I don't know what to do, there is no error message in any log I can find.

Please please help.


Papick G. Taboada

juggledad Jan 31, 2011 08:41 PM

This is the suhosin issue. Do a forum search

pgtaboada Jan 31, 2011 08:45 PM

I do not have it installed.

I have dozens of this here in my logs:

PHP Warning: include(): Failed opening 'bfa://post_footer_style_links_hover' for inclusion (include_path='.:')

I read the suhosin threads, even added the config to my .htaccess although I don't have it installed, did not work.


juggledad Feb 1, 2011 04:37 AM

please do the following. Add the following to ato->Style & edit CENTER COLUMN->Content ABOVE the LOOP as the very first line
HTML Code:

<?php if (is_user_logged_in()) { echo phpinfo(); } ?>
then login to your site and visit the site.

You will see a dump of the phpinfo in the center area. Make a copy of the source and attach it to a reply.

Then remove the code

This will only show up if someone is logged into the site.

pgtaboada Feb 1, 2011 05:25 AM

You are right!

Just learned that Ubuntu 10.04 comes with a suhosin pathed PHP.

I am trying all kind of configuration options now, none are working. I'll post it when I get it running.

pgtaboada Feb 1, 2011 06:20 AM

Not working yet, I am running out of options.

I have ubuntu 10.04 with a hardened php (patch) on a self hosted server.

I added to my php.ini:


hphp.executor.include.whitelist = bfa://
It did not work. Most people mention suhosin.* properties, only ther hphp page mentions hphp.* properties. Either way, nothing worked.

So I installed suhosin (the module), added it to my php.ini (*.so thing).

And than I added to my php.ini:


suhosin.executor.include.whitelist = bfa://
and I tried


suhosin.executor.include.whitelist = bfa://

in the suhosin.ini config.


All times are GMT -6. The time now is 12:43 AM.

Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.