Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   eCommerce & Atahualpa (http://forum.bytesforall.com/forumdisplay.php?f=31)
-   -   Upgraded wp-ecommerce plugin - numerous display issues (http://forum.bytesforall.com/showthread.php?t=21160)

im1dermike Nov 19, 2013 05:54 AM

Upgraded wp-ecommerce plugin - numerous display issues
 
I created a WP e-commerce site for a friend a year ago and haven't touched it since initially getting things working. She contacted me recently that she was unable to add new items so I upgraded the WP e-commerce plugin (to 3.8.12) which resolved the issue with being unable to add new products, but now her site has a handful of other display issues.
  • The categories page (in Default View) looks a mess. It has no images and information about products within each category is listed vertically without any differentiation between products.
  • On the products page, the description text for each product wraps below the product image rather than being on the side (again in Default View).
  • I'm trying to display 3 widgets in the right sidebar and it's not appearing on at least 2 pages (Categories and Products if that means anything). I have every checkbox checked in the RIGHT sidebar: Display on section and have not explicitly entered any page IDs to exclude. On the Categories page, like I said, there is no sidebar. And when I inspect the markup the tr#bodyrow only has a td#middle; there is no td#right.

On every page, in my browser's console window, I see an error that the following file is missing: /wp-content/plugins/wp-e-commerce/wpsc-theme/wpsc-iShop.css?ver=3.8.12.1.55f8cfa0d7. Not sure what the deal with that is...

What do I need to do to resolve these issues? Thanks in advance.

ps. The site is http://www.brooksmountainsoap.com if that helps. And I'm using Atahualpa 3.7.12.

juggledad Nov 19, 2013 06:14 AM

You need to contact the plugin author

im1dermike Nov 19, 2013 06:23 AM

How are you going to direct me to this subform in another thread and then, when I do, tell me this isn't the right place to post such a question? Also, what would the purpose of this subforum be if not to help answer questions regarding Atahualpa and ecommerce plugins?

juggledad Nov 19, 2013 06:38 AM

In the other thread you stated you have problems with the sidebars. Issues like that have been previously addressed so searching thru those threads could give you the answer.

In this thread you state you are seeing a message that there is a missing plugin file. That has nothing to do with the theme so you need to ask the plugin author.

I'd be happy to look into both issues in detail, send me a PM if you are interested and I'll give you my rate.

dwsproduction Aug 12, 2014 05:53 PM

Hi im1dermike,

Even though it has been a long time since you have posted this and may have fixed this/found another solution, I thought I'd mention the solutions for anyone else finding themselves on this page and lost for direction.

Problem 1 - Categories page and/or product list page all messed up, not showing pictures, text formatting, or even the Add to Cart button.

This is because the theme is set to display excerpts on Post category pages (which strips almost all formatting) and the newer versions of WP e-Commerce uses Post style product and category listings.

The solution: Go to Atahuapla Theme Options > Post & Pages > Configure EXCERPTS.
Under Except length - increase this number if you want the full product description to be displayed.
Under Don't strip these tags, add
<header><h1><h2><h3><h4><div><a><p><form><fieldset ><option><select><legend><table><tr><td><input><im g><footer><span><strong><i><b><font><em><br><br />

If you wanted you could also; Under headings such as Posts or excerpts on CATEGORY pages, etc, change from Excerpts Only to Full Posts.

I assume these changes would affect any blog post areas of your site too. The sites I've done these changes on were pure commerce without any blog style articles.

Problem 2 - I have no immediate solution for this.

Problem 3 - No right sidebar on category and product pages.

Juggledad found the solution here - http://forum.bytesforall.com/showthread.php?t=17880. Summary;
It seems that the plugin is using SESSION's and that is messing up the Theme variables, but this might provide a 'get around' for it.

edit footer.php and change line 3 from
HTML Code:

if (!isset($bfa_ata))

to
HTML Code:

if ((!isset($bfa_ata)) or (class_exists('WP_eCommerce')) )

I don't know if it has affected you but my footer gets mashed up when using Atahualpa with WP e-Commerce - it gets squished into the left sidebar leaving a white gap at the bottom, in the middle and right side bar.

The solution; Edit footer.php;
Fix; edit theme file footer.php to remove the theme-controlled colspan attribute.

Change:
<!-- Footer -->
<td id="footer" colspan="<?php echo $cols; ?>">

To:
<!-- Footer -->
<td id="footer" colspan="2"> (2 for a 1 side bar site, 3 for a 2 sidebar site)

Hope this helps. If you find these tips helpful, please consider donating to Juggledad ;)


All times are GMT -6. The time now is 11:55 PM.

Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.