Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Plugins & Atahualpa (http://forum.bytesforall.com/forumdisplay.php?f=16)
-   -   [SOLVED] follow-up: Error in css.php on line 137 and 138 (http://forum.bytesforall.com/showthread.php?t=24066)

aharonium Dec 17, 2019 04:55 AM

[SOLVED] follow-up: Error in css.php on line 137 and 138
 
Apologies for the new thread. The forum wouldn't let me reply to the old thread here

After a long while, I took another look at the error_log.

The errors disappeared when I added Layout MIN and MAX width numbers into the Style and Configure Layout Options.

When I removed the numbers and saved, the errors returned. So the issue appears to be that blank MIN/MAX Width layout options will produce these error messages for some reason.

Also, I did not mention this earlier but it seems like it could be relevant. There is one more error -- a PHP Warning -- that shows up just before the other errors I mentioned before.

Code:

[17-Dec-2019 10:50:20 UTC] PHP Warning:  call_user_func_array() expects parameter 1 to be a valid callback, no array or string given in /.../wp-includes/class-wp-hook.php on line 288
[17-Dec-2019 10:50:20 UTC] PHP Warning:  A non-numeric value encountered in /.../wp-content/themes/atahualpa/css.php on line 137
[17-Dec-2019 10:50:20 UTC] PHP Warning:  A non-numeric value encountered in /.../wp-content/themes/atahualpa/css.php on line 138

That PHP Warning error continued to show even after I took care of the issue causing the other errors.

Code:

[17-Dec-2019 11:15:17 UTC] PHP Warning:  call_user_func_array() expects parameter 1 to be a valid callback, no array or string given in /.../wp-includes/class-wp-hook.php on line 288
[17-Dec-2019 11:15:19 UTC] PHP Warning:  call_user_func_array() expects parameter 1 to be a valid callback, no array or string given in /.../wp-includes/class-wp-hook.php on line 288
[17-Dec-2019 11:15:27 UTC] PHP Warning:  call_user_func_array() expects parameter 1 to be a valid callback, no array or string given in /.../wp-includes/class-wp-hook.php on line 288

I'm running PHP 7.1.

juggledad Dec 27, 2019 01:35 AM

Your post in the other thread was in a moderation state. It has been approved and I responced there. Lets keep using that thread too all the information is in one place.

I'm closing this thread.


All times are GMT -6. The time now is 04:02 AM.

Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.