Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Atahualpa 3 Wordpress theme (http://forum.bytesforall.com/forumdisplay.php?f=2)
-   -   [SOLVED] Blockquotes behind images (http://forum.bytesforall.com/showthread.php?t=16616)

Eleonora Jan 27, 2012 08:54 AM

[SOLVED] Blockquotes behind images
I'm having a little issue with blockquotes: I run a book blog, and i like to put the summary of the book with the cover. I use the blockquote for the summary, but I can't put the blockquote behind the image. It goes under, leaving a lot of empty lines. Is there any way to fix this? I want my blockquotes to look like this http://www.thestorysiren.com/
Thank you :)

lmilesw Jan 27, 2012 12:33 PM

Try changing or adding the display line in the blockquotes style box to display: table

Eleonora Jan 27, 2012 02:33 PM

I'm sorry, but I'm really new at this and I don't know what to change. Can you explain it?

lmilesw Jan 27, 2012 08:01 PM

In the theme options there is a Blockquotes section. If you add
HTML Code:

display: table;
into that section it may take care of your issue. The box will then look something like the following.
HTML Code:

color: #555555;
padding: 1em 1em;
background: #f4f4f4;
border: solid 1px #e1e1e1;
display: table;

Eleonora Jan 28, 2012 09:49 AM

I've tried, but it keeps showing the blockquote under the image :(

lmilesw Jan 28, 2012 11:28 AM

Have you tried it with !important added? This is where I use Firebug to try out different code and see what works.

Eleonora Jan 30, 2012 06:26 AM

Yes. I'll copy the code I'm using so you can tell if I'm doing it right.


font-style: italic;
color: #4A5759;
padding: 1em 1em;
background: #F4F4F4;
border: dashed 5px #D7DBDD;
display: table !important;
Anyway, thank you for helping me!

lmilesw Jan 30, 2012 06:36 AM

I don't see that in your source. Where are you putting the code and what version of Atahualpa and WordPress are you on?

Eleonora Jan 30, 2012 07:06 AM

I'm using the 3.7.3 Atahualpa version and WP 3.3.1.
I'm putting the code in the 'style blockquote' section of the Atahualpa theme options.
What do you mean with

I don't see that in your source.
This is my blog: http://www.thebooknerd.net/
you can see in the first post how blockquotes look with an image. And this: http://www.thestorysiren.com/2012/01...ah-tregay.html is an exemple of what i'd like them to look. It's just the position of the blackquote that I want to change, not the colors, border etc.
I hope I'm explaing it right, english is not my first language.

lmilesw Jan 30, 2012 07:23 AM

Sorry... I was looking at the example site. I am not sure where the clear is coming from but to fix the issue try adding clear: none; or clear: none !important; to your code for blockquotes.

Eleonora Jan 30, 2012 07:34 AM

Whit the "clear: none;" code it puts the blockquote on the right of the image, but it keeps on leaving a lot of empty space on the left. (Can you see it here? : http://www.thebooknerd.net/2012/01/0...nal-devices-2/)

lmilesw Jan 30, 2012 08:03 AM

That's what I originally thought you were looking for. If you now take out the display: table you should be all set.

Also I am coming up with these suggestions by using Firebug. It is a tool I think anyone building sites needs to become familiar with.

Eleonora Jan 30, 2012 08:26 AM

Thank you so much. I've just downloaded firebug (i didn't even know something like that existed!) and i'll try to learn how to use it.
Again, thank you for your time and your help :)

All times are GMT -6. The time now is 04:44 PM.

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.