Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Comments, trackbacks & pings (http://forum.bytesforall.com/forumdisplay.php?f=19)
-   -   [SOLVED] No one can leave a comment (http://forum.bytesforall.com/showthread.php?t=9772)

CPS Sep 20, 2010 12:49 PM

[SOLVED] No one can leave a comment
I need help. No one can leave a comment regarding my posts. I'm new to this so I'm sure I didn't click the right box. Please help. Thanks.

juggledad Sep 20, 2010 01:01 PM


CPS Sep 20, 2010 02:45 PM


I've searched the past two days and I still nothing. I'll keep searching.

juggledad Sep 20, 2010 02:50 PM

what version of Atahualpa and WP?
What is the url?
what is your setting at dashboard->settings->discuessions

CPS Sep 20, 2010 06:16 PM

WP 3.0.1

Settings: These are all checked.

Attempt to notify any blogs linked to from the article.
Allow link notifications from other blogs (pingbacks and trackbacks.)
Allow people to post comments on new articles

The only ones checked below are the Automatically close comments and Enable threaded comments. The others are not checked.

Other comment settings Comment author must fill out name and e-mail
Users must be registered and logged in to comment
Automatically close comments on articles older than days
Enable threaded (nested) comments 2345678910 levels deep
Break comments into pages with top level comments per page and the lastfirst page displayed by default
Comments should be displayed with the oldernewer comments at the top of each page


juggledad Sep 20, 2010 06:19 PM

Ah, the comments are not CLOSED, you just can't comment.

try disabling all your plugins and see if there is a conflict

CPS Sep 20, 2010 06:33 PM

I'm sorry to sound like a beginner. Do you mean deactivate plugins?

Thanks for your help.

CPS Sep 20, 2010 07:12 PM

I deactivated all my plugins and you still can't leave a comment.

juggledad Sep 20, 2010 07:25 PM

Ok, swap to the default theme for a bit and see if you can enter a comment.
If not try switching the permalinks to the default if the are set to anything else

CPS Sep 21, 2010 08:44 AM

I tried last night and this mornning in using the default theme and it didn't work. Then I tried other themes and they didn't work.

juggledad Sep 21, 2010 08:48 AM

This isn't a theme problem them. I noticed that all links have the same issue.

Try setting the permalinks (dashboard->settings->permalinks) back to the default - it may be a problem in your htaccess file

CPS Sep 21, 2010 08:53 AM

Permalink > common settings - it was already marked default. I saved it anyway. Still nothing.

lmilesw Sep 21, 2010 09:31 AM

What do you have the the WordPress Address and Site Address fields in the WordPress General settings? If the URL for your site is http://www.secsportsblog.com and not http://www.secsportsblog.com/blog1 then you should have http://www.secsportsblog.com in both of these fields.

The only page I can get to is http://www.secsportsblog.com/blog1 no matter what I click on.

juggledad Sep 21, 2010 09:33 AM

what is your settings at dashboard->settings->general for both
WordPress address (URL)
Site address (URL)

Has the site ever worked?

(I'll be gone for about 2 hrs)

CPS Sep 21, 2010 09:51 AM

I did have www.secsportsblog.com/blog1. I did change it to www.secsportsblog.com. After I saved it, now it reads 404 page not found. I can't even log in. Should I go to Network Solutions and repair blog?

lmilesw Sep 21, 2010 11:34 AM

All you have to do to "fix" this issue is login to your control panel, go to your database and change a couple of path statements back to including the blog1 at the end. If you are not sure about how to do this send me a PM.

CPS Sep 21, 2010 12:22 PM

I PM you. Please show me. Thanks.

Mamapumpkin Apr 29, 2011 11:11 AM

Hi guys, I'm having the same problem. I haven't made any changes but suddenly, nobody can comment. They could in the morning but by afternoon, poof! I've disabled all plugins and that didn't work. I've tried searching wordpress forums for help and have looked through here for help.....still can't find it. I've spent 2 days searching for how to fix this. Can anyone help?

I'm using:

Atahualpa 364
Wordpress 3.1.2
My site: www.mamapumpkin.com

juggledad Apr 29, 2011 11:22 AM

1) what are the discussion settings (dashboard->settings->Discussion)?
2) on your latest post - is the 'Allow Comments' field checked?

Mamapumpkin Apr 29, 2011 11:26 AM

Discussion settings: http://mamapumpkin.com/wp-admin/options-discussion.php (sorry, I'm not sure if you're able to access that but how would I explain what those settings are?)

And yes, comments are allowed on every post.

Thank you for your time!

juggledad Apr 29, 2011 11:33 AM

No I can't get to that page
also If I go to 'Before I was a Mom……..' I see the comment form

Mamapumpkin Apr 29, 2011 11:35 AM

There is a comment form but if you try leaving a comment, nothing happens. *sob*

lmilesw Apr 29, 2011 12:04 PM

I just left a comment and it looked like it worked. You should see a draft comment that says test from forum.

juggledad Apr 29, 2011 12:11 PM

did you change your permalinks?
did you add a plugin?
try disabling all your plugins

Mamapumpkin Apr 30, 2011 08:38 AM

Hi Juggledad,

I did go into permalinks after seeing a suggestion by Flynn but that didn't work and I no longer know what was originally there.

I haven't added any new plugins and I've disabled all plugins and people still can't make comments.

I did however find that I have 2 unknown administrators within my site! I've deleted them now.

Any more ideas?

juggledad Apr 30, 2011 02:39 PM

if You will send me a PM with a admin ID/pw I'll take a look, might not be till tomorrow afternoon though

interage May 15, 2011 07:19 AM

Upgrade your Atahualpa.

I just ran into the same issue - folks were coming to my site, and getting the message "you must be logged in to comment" - even when they were logged in.

I couldn't comment either - and this was working fine before. (the site's been up forever.)

Upgraded ATA - and all is well.

Hope this helps!


cway Aug 16, 2011 11:08 AM

I'm experiencing this same problem.
I have someone using Atahualpa 3.6.7 and Wordpress 3.2.1
Not checked: Users must be registered and logged in to comment
Allow Comments is checked for the page comments are welcomed.
Any ideas?

lmilesw Aug 16, 2011 12:08 PM

I see comments on some of the posts. Where can't people make comments?

cway Aug 16, 2011 12:24 PM


juggledad Aug 16, 2011 03:26 PM

what is ato->Style & configure COMMENTS->Allow comments on "Page" pages, too?

cway Aug 17, 2011 09:06 AM

That was it.

All times are GMT -6. The time now is 07:08 AM.

Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.