Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Old Version fixes and change logs (http://forum.bytesforall.com/forumdisplay.php?f=37)
-   -   Atahualpa 3.6.4 released (http://forum.bytesforall.com/showthread.php?t=12559)

juggledad Jan 31, 2011 07:13 PM

Atahualpa 3.6.4 released
Download Atahualpa 3.6.4 here

This version is in the review queue at wordpress.org but not listed yet

* BUGFIX 361-01: meta tags not appearing in generated source
* BUGFIX 361-02: Tab order on comment form incorrect when user is not logged in
* BUGFIX 361-03: Allow Tag widget links to use Atahualpa widget link styling.
* BUGFIX 361-04: Allow Custom Menu widget links to use same styling as Pages widget.
See also http://forum.bytesforall.com/forumdisplay.php?f=12

2 new options:

* “Style & configure LAYOUT” -> “Emulate IE7″. Defaults to ‘No’ and will only generate the line
HTML Code:

<meta http-equiv=”X-UA-Compatible” content=”IE=EmulateIE7″ />
when set to ‘Yes’
* “Header Image” -> “Overlay Header Image”
The Overlay Header Image area allows you to put in HTML which will overlay the header image

damian Feb 1, 2011 11:45 PM

Is there an easy way to update Atahualpa on my site simply by clicking a button or two, rather than having to download and upload all of the files manually?

Carlo Feb 2, 2011 02:20 AM

I get errors on three sites. One of them doesn't see any posts or pages any more after upgrading; two others give blank pages all over.

With other installations, with the exact same WP version and plugins, I have no problems whatsoever. Any ideas, any-one? I'll be looking further and will tell if I find anything useful.

BTW: I have exported all settings from the previous ATA into the new one......

Carlo Feb 2, 2011 03:53 AM

After some testing I can only come to the conclusion that the theme doesn't see my database somehow. All posts and pages are missing and I get the "you're looking for something that isn't there" error. When I switch back to version 3.5.3, everything is back to normal again.

I am unable to find any system in there, alas...

Carlo Feb 2, 2011 05:49 AM

I am still searching, but I found out that if I use the 'Delete bfa4' button, then the theme does see my posts and pages, but all my settings are gone. If I then import the settings from the previous version, I get the errors again. So the fault sits somewhere in an ATA setting, but which one? That is now the interesting question.

juggledad Feb 2, 2011 06:20 AM

Carlo, please attach your setting file to a reply

Carlo Feb 2, 2011 08:01 AM

1 Attachment(s)
Here are my settings..... Hope they reveal their dark secrets to you.... :-)

juggledad Feb 2, 2011 09:14 AM

what release did you create the export on?

Carlo Feb 2, 2011 10:29 AM

I had to go back to 3.5.3 before I could make an export.

DanGarion Feb 2, 2011 11:44 AM

1 Attachment(s)
I'm getting some weirdness when I'm trying to update. I am currently running 3.5.2 when I upload 3.6.4 and then active I get a 404 error with no styling and the body area is missing all content.

I went back to my old version and then did an export, changed to 3.6.4 and did an import and things still look broke. I tried disabling my caching and that didn't resolve it either.

I've attached my settings for your review.

interfasys Feb 2, 2011 05:09 PM

This could be related to the fact that 3.6.x is using php streams to load some of the content. I've had issues with Suhosin, but there could be other reasons.

lmilesw Feb 2, 2011 06:09 PM

Carlo and DanGarion... Juggledad and I just spent a bunch of time getting to the bottom of the import export issues. While we are not certain as to what caused the errors we have found what looks to be a fix. There were some lines in the exported styles that should not have been there. Attached are the edited files for you to try importing and see how they work. They are named accordingly.

Carlo Feb 3, 2011 01:42 AM

My dear Gents. IT WORKED! Unbelievable. Now the big question: can I do this myself? I have two other sites with the same problem....

I think you guys are simply AMAZING!

juggledad Feb 3, 2011 04:30 AM

Carlos, could I get admin access to one of those sites. I'd like to poke around and see if I can figure out why it happens to you but not me. If so, send me a PM with an admin ID/PW thanks

paolo-from-italy Feb 3, 2011 04:57 AM

if you want,I can give you my site with the same problem...

juggledad Feb 3, 2011 06:02 AM

Yes please send me a admin ID/PW in a PM

Carlo Feb 3, 2011 07:48 AM

2 Attachment(s)
Hey Mister Juggledad,

I have two attachments for you, made by exporting from 3.5.3 as the other one. These two sites give the same problem. If you still need access to one of them, I can do that tomorrow....

BTW: they all run on the same server.....

lmilesw Feb 3, 2011 08:05 AM

I'm not seeing the same issues with those two file Carlo.

juggledad Feb 3, 2011 08:47 AM

Carlos, as Larry said, both of those import fine. some times I have to import them twice to get the green 'import successful message'

Cheers Feb 3, 2011 01:15 PM

Another small problem with upgrade to 3.6.4. My favicon doesn't show. I checked the header.php and css.php and the lines <?php global $templateURI; ?> seem to be there in a modified form. (taken from 3.6 upgrade problems.

Please advise when convenient, :):)

DanGarion Feb 3, 2011 03:59 PM


Originally Posted by lmilesw (Post 56787)
Carlo and DanGarion... Juggledad and I just spent a bunch of time getting to the bottom of the import export issues. While we are not certain as to what caused the errors we have found what looks to be a fix. There were some lines in the exported styles that should not have been there. Attached are the edited files for you to try importing and see how they work. They are named accordingly.

Thanks that worked! ;)

lmilesw Feb 3, 2011 06:42 PM


Do the default favicons work?

bvision Feb 6, 2011 01:34 AM

I am a little disappointed with this version. Since version 3.5.3 it does not work for me. I get only a blank screen. It must be easy to look for the differences between the versions and find a cause and offer a solution, or go back... A theme should always work. I think I'll just go looking for a new theme. And yes, I tried every solution you offered. No cache, tried the ini, send my info.php but no response.:(

juggledad Feb 6, 2011 04:42 AM

I'm sorry you are having problems. Due to WordPress requirements, Flynn - the developer of Atahualpa, had to make some code changes.

One of these code changes can cause a conflict if 'Suhosin' is installed as part of PHP on a site. The solution is to tell Suhosin to whitelist the BFA code. This is detailed in one of the other posts.

Different sites have different versions of PHP installed. For example, on the host I use (I'm a long time customer) Suhosin is not part of PHP, however for new sites at the same host, Suhosin IS part of PHP!! (i discovered this when setting up a site fot a customer of mine) I guess that new users are on a different server.

Then comes the issue of how much control your host allows you. I can go in and edit the php.ini for my site and restate the server, others can add a php.ini override, some can't use a php.ini at all and have to contact their host's tech support to get past this issue.

Also, when you add a post to an existing thread it can get lost. My suggestion is one user/one issue pre thread.

If you decide to switch themes, I wish you best of luck.

bushtool Feb 9, 2011 02:45 PM

1 Attachment(s)
I am having the same problem as Carlo. 3.5.3 to 3.6.4, database is no longer found after upgrading.

juggledad Feb 9, 2011 03:01 PM

did you check to see if you have Suhosin installed?

bushtool Feb 9, 2011 03:11 PM

Do not know what Sahusin is. I never installed it. Using bluehost.

kingmob Feb 9, 2011 03:24 PM


Originally Posted by bushtool (Post 57464)
Do not know what Sahusin is. I never installed it. Using bluehost.

Try this https://www.bluehost.com/cgi/help/164

in my shared account i get a


This server is protected with the Suhosin Patch 0.9.7

suhosin.log.phpscript 0 0
suhosin.log.phpscript.is_safe Off Off
suhosin.log.phpscript.name no value no value
suhosin.log.sapi no value no value
suhosin.log.script no value no value
suhosin.log.script.name no value no value
suhosin.log.syslog no value no value
suhosin.log.syslog.facility no value no value
suhosin.log.syslog.priority no value no value
suhosin.log.use-x-forwarded-for Off Off

bushtool Feb 9, 2011 03:35 PM

1 Attachment(s)
strange cause I am not seeing sohosin anywhere in my phpinfo file

bushtool Feb 9, 2011 03:36 PM

oh I was misspelling my search,

it is showing up there

now what do I do?

juggledad Feb 9, 2011 03:50 PM

read this: Try this if you are getting blank page with Atahualpa 3.6.x

Contact your host and ask them how to whitelist something with suhosin

bushtool Feb 9, 2011 07:11 PM

I'm just not going to upgrade for a while. Who knows, maybe I'll switch to a themeframe theme. The various themes quirks on my sites are starting to drive me crazy.

bushtool Feb 9, 2011 07:12 PM

Thanks for trying to help though.

lgabercrombie Mar 5, 2011 02:48 PM

Attempting to update from Atahualpa 3.5.1 to 3.6.4. Running Wordpress 3.1.
The header and the center column (posts) disappear when I activate 3.6.4. The left and right columns are still there.

My site is stillwaterclub.org

Any ideas?

juggledad Mar 5, 2011 03:39 PM

You may have teh 'suhosin' issue. see if you are getting blank page with Atahualpa 3.6.x (Suhosin issue)

lgabercrombie Mar 5, 2011 04:59 PM

I put a php.ini file with the line "suhosin.executor.include.whitelist = bfa://" in the root directory of my site.

No Joy. :=(

juggledad Mar 5, 2011 07:21 PM

You need to contact your host and find out how to white list something for suhosin

aki Mar 6, 2011 08:50 AM

Thumbnail doesn't work and no except.
I only have the titles

juggledad Mar 6, 2011 10:09 AM

what is your url?

aki Mar 6, 2011 10:11 AM


I go back to 3.5.3


All times are GMT -6. The time now is 08:10 PM.

Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.