Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Page & Category Menu Bars (http://forum.bytesforall.com/forumdisplay.php?f=10)
-   -   [SOLVED] Show full post instead of summary for one-post categories (http://forum.bytesforall.com/showthread.php?t=9263)

hannamargolien Aug 29, 2010 04:36 PM

[SOLVED] Show full post instead of summary for one-post categories
 
Hi, I'm using Wordpress 3.0.1. with Atahualpa 3.5.3.

I have a 2 menu structure, with categories and subcategories in the second menu.

Some of the subcategories will always contain only one post.
When this subcategories are clicked, I would like the full post being shown immediately instead of the summary, so that users don't have to click twice to read the contents of that subcategory.
Thanks for any help.

lmilesw Aug 29, 2010 08:49 PM

One way to do this is the set the excerpts settings in ATO>Configure Excerpts to "Full Posts" instead of "Only Excerpts". Or you could build a custom menu with the WordPress menu system and set the single category posts as a custom menu item pointing to that post.

hannamargolien Aug 30, 2010 03:28 PM

Thanks for the quick reply.

The first solution is not an option as I want multi-post categories to show excerpts and not full posts.

So the second option would be a could solution, only, I don't see where I can set posts as a menu item. I use the custom menu already, but I can only make links to pages or categories, not to posts it seems.

Thanks for further help.

lmilesw Aug 30, 2010 04:34 PM

You would use the custom links tool and enter the URL to the single post.

hannamargolien Aug 31, 2010 02:55 PM

OK,
I found it after looking around a bit.

Apparently, the screen options (in the top right corner of the menu-editing page in WP 3.0.1), only the "pages, categories and theme locations" are set to be shown on screen.

That's why I didn't notice the possibility to create custom links initially.

Maybe other people will have the same problem (I hope, otherwise I will feel stupid).

So to create custom links, open the screen options, check the "custom links" to be shown on screen, and problem is solved.

Thanks for your help, lmilesw!

lmilesw Aug 31, 2010 03:00 PM

Glad you found it. I had forgotten it was "hidden" by default.


All times are GMT -6. The time now is 02:20 AM.

Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.