Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Montezuma Theme (http://forum.bytesforall.com/forumdisplay.php?f=53)
-   -   [SOLVED] Catchable fatal error: (http://forum.bytesforall.com/showthread.php?t=18597)

kal Oct 6, 2012 03:39 PM

[SOLVED] Catchable fatal error:
 
Hi all!

I just installed Montezuma. It looks great. I am getting a weird error on some of the posts when I click on the title:

Code:

Catchable fatal error: Object of class WP_Error could not be converted to string in /home/...../wp-content/themes/montezuma/includes/breadcrumbs.php on line 43
Can someone point me in the right direction?

juggledad Oct 6, 2012 04:45 PM

what is the url

kal Oct 6, 2012 05:00 PM

http://www.mikerielly.com/

juggledad Oct 6, 2012 05:41 PM

What post shows the error?

kal Oct 6, 2012 05:43 PM

Oh jeez. Sorry about that. I switched to Atahualpa.

I switched it back to Montezuma. Click on any post title. You will see what I mean.

Thanks for your help!

M

kal Oct 6, 2012 05:45 PM

Also I have turned on/off every plugin to see if it was a conflict. Didn't notice a difference.

juggledad Oct 6, 2012 07:12 PM

can you do an Montezuma export (MO->Export/Import) and attach the file to a reply
also is your menu a WP menu? if so what does it have in it ? all Pages? mix of pages and Categories?

kal Oct 6, 2012 07:14 PM

1 Attachment(s)
Here ya go

kal Oct 6, 2012 07:16 PM

menu only has 2 pages

juggledad Oct 6, 2012 07:16 PM

also is your menu a WP menu? if so what does it have in it ? all Pages? mix of pages and Categories?
__________________

kal Oct 6, 2012 07:32 PM

It uses a WP menu. Two pages only, not counting the blog page. No categories.

juggledad Oct 6, 2012 08:07 PM

No categories in the menu or no categories on the site?

kal Oct 6, 2012 08:10 PM

No categories in the menu

kal Oct 6, 2012 08:24 PM

Not sure if this is related, but under WP Settings > Reading
I have "For each article in a feed, show" set to "Full text"
but it continues to show excepts
:confused:

juggledad Oct 7, 2012 04:22 AM

I can't recreate this on a test site so I wonder if I could get in to poke about a bit. If so send me a PM with an admin ID/PW
BTW is that your site? WaterFire is great, unfortunately our schedule never worked this year...sigh...wasn't there one scheduled last night?

kal Oct 7, 2012 04:44 AM

WaterFire is very cool!

Sent PM. Thanks!

juggledad Oct 7, 2012 11:48 AM

Ok, I know what is happening and it is not an issue with the Theme. For some reason, you have posts that have no category - not the category 'uncategorized' the have no category and you can see it in the list of posts in the backend. They have a category of 'Uncategorized' but it is grey and not a link.

All Posts are suppose to have a category and 'Uncategorized' is the default and when you edit a post you will see that category with a check box. If you uncheck it and no other category is check, wordpress rechecks it automatically...except on your site it does not do this and when Montezuma trys to build a breadcrumb using the category, an error occurs because the category is bad.

I changed the post 'They Wore The Red Suit Trailer' by checking the 'Uncategoried' box and now it works fine.

To analyse this further would mean diging into the DB and seeing what is there.

You can get arround it by checking off the 'Uncatogrized' category on all the posts that have no categories checked, but you still have some weird issue going on.

what ever you do, make sure to do a database backup first.

kal Oct 7, 2012 12:30 PM

That helps! Thank you! I just did a mass of posts with "uncategorized". Seems to work okay. How do I get the posts to excerpt? I thought maybe it was related.

kal Oct 7, 2012 05:26 PM

You can close this. The unrecognized category was the issue. Thanks again!


All times are GMT -6. The time now is 05:56 AM.

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.